summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-05 21:57:33 +0300
committerCaleb Maclennan2021-08-05 21:57:33 +0300
commit7e772603b5f49b4033a17949534c94dd2f866aac (patch)
treef1e2889d6ab23f6a4ffd185e4f3a0131d3e492cb
parentdacbdf8dc218315cb5303cb08417db5cb2007d44 (diff)
downloadaur-7e772603b5f49b4033a17949534c94dd2f866aac.tar.gz
upgpkg: mfek-glif-git 1.0a.r70.g574fc59-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ed677bf7fad..1eecc5a23b23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = mfek-glif-git
pkgdesc = A stand-alone glyph viewer and editor (from Modular Font Editor K)
- pkgver = 1.0a.r16.g561930f
+ pkgver = 1.0a.r70.g574fc59
pkgrel = 1
url = https://github.com/MFEK/glif
arch = x86_64
license = Apache
+ makedepends = cargo-nightly
+ makedepends = cmake
makedepends = git
- makedepends = rust-nightly
+ makedepends = python
depends = gtk3
depends = libxcb
- provides = mfek-glif=1.0a.r16.g561930f
+ provides = mfek-glif=1.0a.r70.g574fc59
conflicts = mfek-glif
source = mfek-glif-git::git+https://github.com/MFEK/glif.git
sha256sums = SKIP
pkgname = mfek-glif-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2fc54f8ee6df..a5cf55dd7389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,47 @@
_pkgname=glif
pkgname=mfek-$_pkgname-git
-pkgver=1.0a.r16.g561930f
+pkgver=1.0a.r70.g574fc59
pkgrel=1
pkgdesc='A stand-alone glyph viewer and editor (from Modular Font Editor K)'
arch=(x86_64)
url="https://github.com/MFEK/$_pkgname"
license=(Apache)
-depends=(gtk3 libxcb)
-makedepends=(git rust-nightly)
+depends=(gtk3
+ libxcb)
+makedepends=(cargo-nightly
+ cmake
+ git
+ python)
provides=("${pkgname%-git}=$pkgver")
conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags --abbrev=7 --tags HEAD |
- sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 --tags HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$pkgname"
- cargo fetch --locked
+ cd "$pkgname"
+ cargo fetch --locked --target x86_64-unknown-linux-gnu
}
build() {
- cd "$pkgname"
- cargo build --offline --release --all-features
+ cd "$pkgname"
+ export CARGO_TARAGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname"
+ cargo test --frozen --all-features
}
package() {
- cd "$pkgname"
- install -Dm755 target/release/MFEK$_pkgname "$pkgdir/usr/bin/${pkgname%-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ cd "$pkgname"
+ install -Dm0755 "target/release/MFEK$_pkgname" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}