summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-14 23:33:57 -0500
committerCarlos Aznarán2024-01-14 23:33:57 -0500
commitb146d8155e29311275bc7c8e8049281faaa0dbbd (patch)
treee6059dce147310ef8e343aa7fa9c4c3d01cc1d08
parent5a96989a4e8bbb146133389adc8b93cea9819131 (diff)
downloadaur-b146d8155e29311275bc7c8e8049281faaa0dbbd.tar.gz
Add hypre as hard dependency
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 667080a3ee67..fbcb3065fe41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = mfem
pkgdesc = Lightweight, general, scalable C++ library for finite element methods
pkgver = 4.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mfem/mfem
arch = x86_64
license = custom:BSD-3-clause
makedepends = cmake
depends = gcc-libs
+ depends = blitz
+ depends = hypre
+ depends = openmpi
provides = libmfem.so=4.6-64
source = mfem-4.6.tar.gz::https://github.com/mfem/mfem/archive/v4.6.tar.gz
sha512sums = 8805b4993b6f11abe7ac7dda59d0ddb2e0f5f6b09c2b9c57e665f481cd9bd6b669e63621b38989f70dc8ae38c42a7e8c4e10a1d87a4ac29d53ddd95ce79db0ae
diff --git a/PKGBUILD b/PKGBUILD
index 44634397f991..e3da36e9a641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=mfem
pkgver=4.6
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight, general, scalable C++ library for finite element methods"
arch=(x86_64)
url="https://github.com/${pkgname}/${pkgname}"
license=('custom:BSD-3-clause')
-depends=('gcc-libs')
-makedepends=('cmake')
+depends=(gcc-libs blitz hypre openmpi)
+# gnutls conduit ginkgo hdf5-openmpi libunwind mpfr | sundials scalapack scotch suitesparse superlu_dist
+makedepends=(cmake)
provides=("libmfem.so=${pkgver}-64")
source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('8805b4993b6f11abe7ac7dda59d0ddb2e0f5f6b09c2b9c57e665f481cd9bd6b669e63621b38989f70dc8ae38c42a7e8c4e10a1d87a4ac29d53ddd95ce79db0ae')
@@ -24,8 +25,13 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=TRUE \
+ -DMFEM_USE_MPI=YES \
+ -DHYPRE_DIR=/usr/include/hypre \
+ -DMETIS_DIR=/usr/include/hypre \
-Wno-dev
- cmake --build build
+
+ local N_CORES=$(grep "core id" /proc/cpuinfo | uniq | wc -l)
+ cmake --build build --parallel $N_CORES
}
package() {