summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-25 20:23:39 -0500
committerLuis Martinez2023-03-25 20:23:39 -0500
commiteeb1f2bcfcc2906703fe8cf341e29825551f9d43 (patch)
tree46eea6b22a6db9a7124139bf16bc2827d4fe26da
parent9deb0c9566dcb079f2d8a866589ffc00cbd77690 (diff)
downloadaur-eeb1f2bcfcc2906703fe8cf341e29825551f9d43.tar.gz
update to 4.5.2
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG58
-rw-r--r--PKGBUILD6
3 files changed, 65 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 801a6bb0c771..d7d8ffec1b3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mfem
pkgdesc = Lightweight, general, scalable C++ library for finite element methods
- pkgver = 4.5
+ pkgver = 4.5.2
pkgrel = 1
url = https://github.com/mfem/mfem
changelog = CHANGELOG
@@ -8,8 +8,8 @@ pkgbase = mfem
license = BSD
makedepends = cmake
depends = gcc-libs
- provides = libmfem.so=4.5.0-64
- source = mfem-4.5.tar.gz::https://github.com/mfem/mfem/archive/v4.5.tar.gz
- sha256sums = ee0e640286ea370aaf5c973e8f08eb648fa650e3e30f296e68bfc10c3dcfa9b8
+ provides = libmfem.so=4.5.2-64
+ source = mfem-4.5.2.tar.gz::https://github.com/mfem/mfem/archive/v4.5.2.tar.gz
+ sha256sums = 9431d72a2834078f25c58430767bf2fd62bf43a0feb003189a86847c68b8af4a
pkgname = mfem
diff --git a/CHANGELOG b/CHANGELOG
index 29a018fa78e7..0a92e041b031 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -8,6 +8,64 @@
https://mfem.org
+Version 4.5.2, released on March 23, 2023
+=========================================
+
+- Added support for pyramids in non-conforming meshes. Currently only isotropic
+ refinement is supported in this case.
+
+- Removed the support for the Mesquite toolkit. We recommend using MFEM's TMOP
+ functionality instead for mesh optimization. See the mesh-optimizer miniapp.
+
+- Added a fast normalization-based distance solver, see the Distance miniapp
+ in the miniapps/shifted/ directory.
+
+- Added a new meshing miniapp, Reflector, which reflects a high-order or NURBS
+ hexahedral mesh about a plane.
+
+- Updated logic in FindPointsGSLIB to ignore points found near (but outside) the
+ domain boundary.
+
+- Added an option to auto-balance compound TMOP metrics.
+
+- Fixed a bug in TMOP metric 301.
+
+- When using discontinuous (L2) spaces, use local (element-wise) L2 projection
+ as the coarsening operator for non-conforming AMR meshes.
+
+- Added support for GridFunction::GetGradients() and GetVectorGradient() on
+ face-neighbor elements.
+
+- Added support for pyramids in Gmsh meshes.
+
+- The Mesh Explorer miniapp can now save mesh files in the VisIt or ParaView
+ formats using the corresponding DataCollection. See option 'D' in the menu.
+
+- VisItDataCollection now correctly handles data collection names containing
+ underscores.
+
+- Added support for shared Windows builds with MSVC through CMake.
+ Developers note: this enhancement is facilitated by the addition of the macro
+ MFEM_EXPORT, see config.hpp for more details on its usage.
+
+- The following integrations have updated minimum version requirements:
+ * RAJA >= 2022.10.3
+
+API changes
+-----------
+- The implicit cast methods of class Vector to 'double *' and 'const double *'
+ have been deprecated and generate deprecation warnings if used. They will be
+ removed in a future release.
+
+- The methods Mesh::GetFaceBaseGeometry and Mesh::GetFaceGeometryType have been
+ deprecated, and Mesh::GetFaceGeometry (which provides identical functionality)
+ should be used instead.
+
+- VisItDataCollection::SetPadDigits() no longer alters the number of digits
+ used to represent the MPI rank because VisIt seems to require 6 digits.
+ This parameter can still be explicitly overridden with SetPadDigitsRank().
+
+
Version 4.5, released on October 22, 2022
=========================================
diff --git a/PKGBUILD b/PKGBUILD
index 41da42266342..6394a09f90ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=mfem
-pkgver=4.5
+pkgver=4.5.2
pkgrel=1
pkgdesc="Lightweight, general, scalable C++ library for finite element methods"
arch=('x86_64')
@@ -9,10 +9,10 @@ url='https://github.com/mfem/mfem'
license=('BSD')
depends=('gcc-libs')
makedepends=('cmake')
-provides=('libmfem.so=4.5.0-64')
+provides=("libmfem.so=$pkgver-64")
changelog=CHANGELOG
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('ee0e640286ea370aaf5c973e8f08eb648fa650e3e30f296e68bfc10c3dcfa9b8')
+sha256sums=('9431d72a2834078f25c58430767bf2fd62bf43a0feb003189a86847c68b8af4a')
build() {
cmake \