summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheowhy2020-11-09 13:25:05 +0100
committerTheowhy2020-11-09 13:25:05 +0100
commitd941b339347585e33632220df37a02c9f782b574 (patch)
tree074f7512697d9c1edbccc1e9dd995a4b1d28d5d3
parentaaf56dc39e3e99cdf510ab06c1e30d2f8353345a (diff)
downloadaur-d941b339347585e33632220df37a02c9f782b574.tar.gz
Update package to 1.4.43
-rw-r--r--.SRCINFO4
-rw-r--r--History.md57
-rw-r--r--PKGBUILD2
3 files changed, 60 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d05efeb4708..f40861b4eabe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mfgtools
pkgdesc = Freescale/NXP I.MX Chip image deploy tools
- pkgver = 1.3.191
+ pkgver = 1.4.43
pkgrel = 1
url = https://github.com/NXPmicro/mfgtools
changelog = History.md
@@ -12,7 +12,7 @@ pkgbase = mfgtools
depends = zlib
depends = libusb
depends = openssl
- source = git+https://github.com/NXPmicro/mfgtools#tag=uuu_1.3.191
+ source = git+https://github.com/NXPmicro/mfgtools#tag=uuu_1.4.43
source = uuu-complete.bash
sha256sums = SKIP
sha256sums = SKIP
diff --git a/History.md b/History.md
index eae069ce5953..cd20cdecb3f0 100644
--- a/History.md
+++ b/History.md
@@ -1,4 +1,61 @@
+uuu_1.4.43 / 2020-08-10
+=======================
+
+ * fix windows env param read terminates command
+ * fix multiple occurrence of @ variables
+ * try to fix travis build failure
+ * add parameter to modify enviroment variables
+ * add environment variable support command
+ * Fix some typo at error message
+ * Added support for 'FB:reboot' and 'FASTBOOT:reboot'
+ * Simplify notify.cpp
+ * Modernize version.cpp
+ * Minor adjustments to error handling definitions
+ * Solve leftover compiler warnings for rominfo.h
+ * Deduplicate GetFlashHeaderSize
+ * Introduce offsets to GetFlashHeaderSize
+ * Modernize CheckHeader
+ * Further simplify both search_rom_info functions
+ * Modernize search_rom_info(const char *s)
+ * Drop "using namespace std" directive from buffer.h
+ * Reduce visibility of Zip_file_info members
+ * Add missing "pragma once" to http.h
+ * Reduce visibility of Fat class members
+ * Reduce visibility of class members in fastboot.h
+ * Reduce visibility of a further few variables
+ * Reduce visibility of members of CmdBase
+ * Forbid copying CmdCtx
+ * Adjust SDPCmdBase
+ * Adjust SDPWriteCmd
+ * Adjust SDPReadMemCmd
+ * Adjust SDPDcdCmd
+ * Minor changes to help code models
+ * Make member variable of SDPSCmd private
+ * Adjust SDPWriteMemCmd
+ * Adjust SDPJumpCmd
+ * Add more override specifiers in trivial places
+ * Adjust SDPBootCmd
+ * Adjust Backfile
+ * Adjust m_socket within HttpStream
+ * Fix compiler warnings for uuu.cpp
+ * Move function prototypes to source that uses them
+ * Drop using namespace std directive from config.h
+ * Use default member initializer in HttpStream
+ * Modify HttpStream member function visibility
+ * Forbid copying TransBase
+ * Drop using namespace std directive from trans.h
+ * Make BulkTrans fields private and some const
+ * Make fields of HIDTrans private
+ * Make USBTrans::m_EPs protected
+ * Reduce visibility of TransBase::m_devhandle
+ * Drop unused m_path member from TransBase
+ * allow to pass sparse limit from command line
+ * fix #193 fb:< echo ucmd print failure
+ * fix fat_write partition parser error
+ * Update version number support build number > 255
+ * libuuu/CMakeLists.txt: don't overwrite CMAKE_CXX_FLAGS
+
uuu_1.3.191 / 2020-05-08
========================
diff --git a/PKGBUILD b/PKGBUILD
index 6c56076b3e23..aba724b816ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Theowhy <aur.theowhy@shizoku.fr>
# Contributor: jpkotta
pkgname=mfgtools
-pkgver=1.3.191
+pkgver=1.4.43
pkgrel=1
pkgdesc="Freescale/NXP I.MX Chip image deploy tools"
arch=(x86_64)