summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author企鹅20352022-07-23 07:51:04 +0800
committer企鹅20352022-07-23 07:51:04 +0800
commitd0de834d8165b61af1fff67ec640a2a0894ff22e (patch)
treef07a46dec77d70880aa070b52e776115b1108f2d
downloadaur-d0de834d8165b61af1fff67ec640a2a0894ff22e.tar.gz
init
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD47
-rw-r--r--mfosu6
-rw-r--r--mfosu.desktop8
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99711223a229
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = mfosu-bin
+ pkgdesc = An fork of osu!lazer.
+ pkgver = 2022.528.0
+ pkgrel = 1
+ url = https://github.com/MATRIX-feather/osu
+ arch = x86_64
+ license = MIT
+ license = custom:CC-BY-NC 4.0
+ depends = zlib
+ depends = libgl
+ depends = fuse2
+ depends = osu-mime
+ provides = osu-lazer
+ provides = mf-osu
+ provides = mfosu
+ noextract = mfosu.AppImage
+ options = !strip
+ source = https://dl.hiosu.com/%e6%9c%ac%e5%9c%b0%e4%b8%8b%e8%bd%bd%e7%82%b9%e2%91%a1%20-%20%e5%85%b6%e4%bb%96%e7%bd%91%e7%bb%9c%e6%8e%a8%e8%8d%90/Linux%e7%89%88%282022.528.0%29/mfosu.AppImage
+ source = https://github.com/MATRIX-feather/osu/raw/stable/assets/lazer.png
+ source = https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md
+ source = mfosu.desktop
+ source = mfosu
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = mfosu-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da6e1496e1e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mfosu-bin
+pkgver=2022.528.0
+pkgrel=1
+pkgdesc="An fork of osu!lazer."
+arch=(x86_64)
+url="https://github.com/MATRIX-feather/osu"
+license=(
+ "MIT"
+ "custom:CC-BY-NC 4.0"
+)
+depends=(
+ zlib
+ libgl
+ fuse2
+ osu-mime
+)
+provides=(
+ osu-lazer
+ mf-osu
+ mfosu
+)
+options=(!strip)
+source=(
+ "https://dl.hiosu.com/本地下载点① - 电信网络推荐/Linux版($pkgver)/mfosu.appimage"
+ "https://github.com/MATRIX-feather/osu/raw/stable/assets/lazer.png"
+ "https://raw.githubusercontent.com/ppy/osu-resources/master/LICENCE.md"
+ "mfosu.desktop"
+ "mfosu"
+)
+noextract=("mfosu.appimage")
+sha256sums=(
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
+package() {
+ cd "$srcdir"
+ # Install binary and launch script
+ install -Dm755 "mfosu.appimage" "$pkgdir/opt/mfosu/mfosu.appimage"
+ install -Dm755 -t "$pkgdir/usr/bin" mfosu
+ # Install pixmap, desktop and license file
+ install -Dm644 lazer.png "$pkgdir/usr/share/pixmaps/mfosu.png"
+ install -Dm644 -t "$pkgdir/usr/share/applications" mfosu.desktop
+ install -Dm644 -t "$pkgdir/usr/share/licenses/mfosu" LICENCE.md
+}
diff --git a/mfosu b/mfosu
new file mode 100644
index 000000000000..9ff504b88bb1
--- /dev/null
+++ b/mfosu
@@ -0,0 +1,6 @@
+#!/bin/sh
+DATADIR=$HOME/.local/share/osu
+if [ ! -d $DATADIR ]; then
+ mkdir -p $DATADIR
+fi
+env OSU_EXTERNAL_UPDATE_PROVIDER=1 /opt/mfosu/mfosu.appimage "$@"
diff --git a/mfosu.desktop b/mfosu.desktop
new file mode 100644
index 000000000000..8f853f7d5c50
--- /dev/null
+++ b/mfosu.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=mfosu
+MimeType=application/x-osu-skin-archive;application/x-osu-replay;application/x-osu-beatmap-archive;x-scheme-handler/osu;
+Icon=/usr/share/pixmaps/mfosu.png
+Comment=Open source free-to-win rhythm game
+Exec=/usr/bin/mfosu
+Categories=Game;