summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2023-06-15 04:42:42 +1200
committerVaporeon2023-06-15 04:42:42 +1200
commitd6bf5f03b321f30530405e230cd6d157afc68180 (patch)
tree5c4a282c83540614eba98560b14075fe61bd5bc8
parente4744d7d30b615bfc4781d4133a5e36bafe0172b (diff)
downloadaur-d6bf5f03b321f30530405e230cd6d157afc68180.tar.gz
Add lua dep
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9051afc4a6cb..8a4c15df4838 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = mgba-git
- pkgver = 0.11.0.r8035.45762c8f9
+ pkgver = 0.11.0.r8129.58da73864
pkgrel = 1
url = http://mgba.io/
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = mgba-git
makedepends = libpng
makedepends = libzip
makedepends = libedit
+ makedepends = lua
makedepends = ffmpeg
makedepends = desktop-file-utils
makedepends = qt5-tools
@@ -25,6 +26,7 @@ pkgname = libmgba-git
depends = libpng
depends = libzip
depends = libedit
+ depends = lua
depends = ffmpeg
depends = sqlite
provides = libmgba
@@ -32,14 +34,14 @@ pkgname = libmgba-git
pkgname = mgba-sdl-git
pkgdesc = A Nintendo Gameboy Advance Emulator focusing on both speed and accuracy (git build)
- depends = libmgba
+ depends = libmgba-git
depends = sdl2
provides = mgba-sdl
conflicts = mgba-sdl
pkgname = mgba-qt-git
pkgdesc = A Nintendo Gameboy Advance Emulator focusing on both speed and accuracy. Qt5 UI. (git build)
- depends = libmgba
+ depends = libmgba-git
depends = qt5-multimedia
depends = sdl2
provides = mgba-qt
diff --git a/PKGBUILD b/PKGBUILD
index d4039ccddf24..171431642a57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgbase=mgba-git
pkgname=('libmgba-git' 'mgba-sdl-git' 'mgba-qt-git')
-pkgver=0.11.0.r8035.45762c8f9
+pkgver=0.11.0.r8129.58da73864
pkgrel=1
arch=('x86_64')
url='http://mgba.io/'
license=('custom:MPL2')
makedepends=('cmake' 'qt5-multimedia' 'sdl2' 'zlib' 'libpng' 'libzip' 'libedit'
- 'ffmpeg' 'desktop-file-utils' 'qt5-tools' 'git' 'ninja')
+ 'lua' 'ffmpeg' 'desktop-file-utils' 'qt5-tools' 'git' 'ninja')
source=("git+https://github.com/mgba-emu/mgba.git")
sha1sums=('SKIP')
@@ -41,7 +41,7 @@ build() {
package_libmgba-git() {
pkgdesc='Shared library of mGBA (git build)'
- depends=('zlib' 'libpng' 'libzip' 'libedit' 'ffmpeg' 'sqlite' )
+ depends=('zlib' 'libpng' 'libzip' 'libedit' 'lua' 'ffmpeg' 'sqlite' )
conflicts=('libmgba')
provides=('libmgba')
@@ -56,7 +56,7 @@ package_libmgba-git() {
package_mgba-sdl-git() {
pkgdesc='A Nintendo Gameboy Advance Emulator focusing on both speed and accuracy (git build)'
- depends=('libmgba' 'sdl2')
+ depends=('libmgba-git' 'sdl2')
conflicts=('mgba-sdl')
provides=('mgba-sdl')
@@ -69,7 +69,7 @@ package_mgba-sdl-git() {
package_mgba-qt-git() {
pkgdesc='A Nintendo Gameboy Advance Emulator focusing on both speed and accuracy. Qt5 UI. (git build)'
- depends=('libmgba' 'qt5-multimedia' 'sdl2')
+ depends=('libmgba-git' 'qt5-multimedia' 'sdl2')
conflicts=('mgba-qt')
provides=('mgba-qt')