summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManhong Dai2019-01-21 15:26:01 -0500
committerManhong Dai2019-01-21 15:26:01 -0500
commit4b9c09a3c3a5b079330d7b8afe7b46a3599b33fc (patch)
tree89bbdd665ec5c6eaa1ffbbc29d4ecd80d468a8b9
downloadaur-4b9c09a3c3a5b079330d7b8afe7b46a3599b33fc.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d191f78adc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mgrep
+ pkgdesc = print lines that match millions of strings efficiently
+ pkgver = 20190121
+ pkgrel = 1
+ url = http://brainarray.mbni.med.umich.edu/mgrep/
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ depends = gcc-libs
+ source = mgrep::git+https://github.com/daimh/mgrep.git
+ md5sums = SKIP
+
+pkgname = mgrep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e31fe03933b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Manhong Dai <daimh@umich.edu>
+pkgname=mgrep
+pkgver=20190121
+pkgrel=1
+pkgdesc="print lines that match millions of strings efficiently"
+arch=('x86_64')
+url="http://brainarray.mbni.med.umich.edu/mgrep/"
+license=('GPL')
+groups=()
+depends=('gcc-libs')
+makedepends=(gcc)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=($pkgname::git+https://github.com/daimh/mgrep.git)
+noextract=()
+md5sums=('SKIP') #autofill using updpkgsums
+build() {
+ cd $pkgname
+ ./configure
+ make
+ rm -f man/$pkgname.1.gz
+ gzip man/$pkgname.1
+}
+check() {
+ $pkgname/src/$pkgname --version
+}
+package() {
+ install -Dm755 $pkgname/src/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname/man/$pkgname.1.gz "$pkgdir/usr/share/man/man1/$pkgname.1.gz"
+}