summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorn17ikh2018-06-29 15:55:03 -0700
committern17ikh2018-06-29 15:55:03 -0700
commitced0df09297cd94fb4cb7e374335cbf591bc62cd (patch)
tree8e5937af5c5ee34e7b47f5f716ba0d478bc735b2
parent423d44891b18d3f5081b00262a1ef9fbbee5e549 (diff)
downloadaur-ced0df09297cd94fb4cb7e374335cbf591bc62cd.tar.gz
Accomodate relocated xattr.h.
xattr.h moved from xattr/xattr.h to sys/xattr.h, preventing compilation.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--xattr_h.patch24
3 files changed, 36 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e372c652c9b7..d682d1b570ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Apr 4 04:58:37 UTC 2018
+# Fri Jun 29 22:54:36 UTC 2018
pkgbase = mhddfs
pkgdesc = fuse filesystem that combines several mount points into a single one.
pkgver = 0.1.39
- pkgrel = 3
+ pkgrel = 4
url = http://mhddfs.uvw.ru/
arch = i686
arch = x86_64
@@ -13,9 +13,11 @@ pkgbase = mhddfs
source = http://mhddfs.uvw.ru/downloads/mhddfs_0.1.39.tar.gz
source = pthreads.patch
source = use_after_free.patch
+ source = xattr_h.patch
md5sums = efc43fa9b4c1437bb233149bd624a459
md5sums = d6476ffcc21897748014815c824652f7
md5sums = c0b6d9d6e7968fd65dacd9ab2ef994f7
+ md5sums = 6287f30042db333ae49f01cfe0d06fab
pkgname = mhddfs
diff --git a/PKGBUILD b/PKGBUILD
index b80fcf3cd67f..f8fdae1ae313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,27 @@
pkgname=mhddfs
pkgver=0.1.39
-pkgrel=3
+pkgrel=4
pkgdesc="fuse filesystem that combines several mount points into a single one."
arch=('i686' 'x86_64')
url="http://mhddfs.uvw.ru/"
license=('GPL3')
depends=('fuse')
makedepends=('uthash')
-source=(http://mhddfs.uvw.ru/downloads/${pkgname}_${pkgver}.tar.gz pthreads.patch use_after_free.patch)
+source=("http://mhddfs.uvw.ru/downloads/${pkgname}_${pkgver}.tar.gz"
+ 'pthreads.patch'
+ 'use_after_free.patch'
+ 'xattr_h.patch')
md5sums=('efc43fa9b4c1437bb233149bd624a459'
'd6476ffcc21897748014815c824652f7'
- 'c0b6d9d6e7968fd65dacd9ab2ef994f7')
+ 'c0b6d9d6e7968fd65dacd9ab2ef994f7'
+ '6287f30042db333ae49f01cfe0d06fab')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
patch -p0 < ${srcdir}/pthreads.patch
patch -p1 < ${srcdir}/use_after_free.patch
+ patch -p0 < ${srcdir}/xattr_h.patch
make
}
diff --git a/xattr_h.patch b/xattr_h.patch
new file mode 100644
index 000000000000..c70f4a4f165e
--- /dev/null
+++ b/xattr_h.patch
@@ -0,0 +1,24 @@
+diff -urb src.orig/main.c src/main.c
+--- src.orig/main.c 2018-06-29 15:48:52.973474879 -0700
++++ src/main.c 2018-06-29 15:47:59.520141549 -0700
+@@ -34,7 +34,7 @@
+ #include <utime.h>
+
+ #ifndef WITHOUT_XATTR
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #endif
+
+ #include "parse_options.h"
+diff -urb src.orig/tools.c src/tools.c
+--- src.orig/tools.c 2018-06-29 15:48:52.973474879 -0700
++++ src/tools.c 2018-06-29 15:48:10.363474879 -0700
+@@ -32,7 +32,7 @@
+ #include <dirent.h>
+
+ #ifndef WITHOUT_XATTR
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #endif
+
+ #include "tools.h"