summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-04-24 20:16:29 +0530
committerlibrewish2020-04-24 20:16:29 +0530
commitd01c3dea694a1c1109dec460f73ed171440331d8 (patch)
tree6af944f8a25406c3effd3fbde5a9eef22129b96e
downloadaur-d01c3dea694a1c1109dec460f73ed171440331d8.tar.gz
init
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
-rw-r--r--mhwd.install28
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e329e336be7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mhwd-garuda-git
+ pkgdesc = mhwd-garuda(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)
+ pkgver = r11.b17a3eb
+ pkgrel = 1
+ url = https://gitlab.com/garuda-linux/applications/mhwd-garuda
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ depends = hwinfo
+ source = git+https://gitlab.com/garuda-linux/applications/mhwd-garuda.git#branch=master
+ sha256sums = SKIP
+
+pkgname = mhwd-garuda-git
+ pkgdesc = mhwd library and application
+ install = mhwd.install
+ depends = hwinfo
+ depends = mesa
+ depends = mhwd-db-garuda
+ depends = uvesafb-dkms
+ depends = pacman
+ optdepends = lib32-mesa: for 32bit libgl support
+ provides = mhwd
+ conflicts = mhwd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e2df4610508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Librewish <librewish@gmail.com>
+# maintainer: Philip Müller <philm[at]manjaro[dog]org>
+# maintainer: Roland Singer <roland[at]manjaro[dog]org>
+
+pkgbase=mhwd-garuda-git
+pkgname=('mhwd-garuda-git')
+pkgver=r11.b17a3eb
+pkgrel=1
+pkgdesc="mhwd-garuda(manjaro's mhwd backported to archlinux with additional features and limited to only dkms drivers)"
+arch=('any')
+_branch='master'
+url="https://gitlab.com/garuda-linux/applications/mhwd-garuda"
+license=('GPL')
+depends=('gcc-libs' 'hwinfo')
+makedepends=('git' 'cmake')
+_git=yes
+source=("git+$url.git#branch=${_branch}")
+sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/mhwd-garuda"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd ${srcdir}/mhwd-garuda
+
+ if [ -e ${srcdir}/../mhwd-${pkgver}-${pkgrel}.patch ]; then
+ patch -Np1 -i ${srcdir}/../mhwd-${pkgver}-${pkgrel}.patch
+ fi
+
+ cmake ./
+ make all
+}
+
+package_mhwd-garuda-git() {
+ pkgdesc="mhwd library and application"
+ depends=('hwinfo' 'mesa' 'mhwd-db-garuda' 'uvesafb-dkms' 'pacman')
+ provides=("mhwd")
+ conflicts=("mhwd")
+ if [ "${CARCH}" = "x86_64" ]; then
+ optdepends=('lib32-mesa: for 32bit libgl support')
+ fi
+ install=mhwd.install
+
+ cd ${srcdir}/mhwd-garuda
+
+ make DESTDIR="${pkgdir}" install
+ install -d -m755 ${pkgdir}/var/lib/mhwd/{db,local}/{pci,usb}
+}
diff --git a/mhwd.install b/mhwd.install
new file mode 100644
index 000000000000..4a3131b9fb5c
--- /dev/null
+++ b/mhwd.install
@@ -0,0 +1,28 @@
+err() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ RED="${BOLD}\e[1;31m"
+ local mesg=$1; shift
+ printf "${RED}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+}
+
+msg() {
+ ALL_OFF="\e[1;0m"
+ BOLD="\e[1;1m"
+ GREEN="${BOLD}\e[1;32m"
+ local mesg=$1; shift
+ printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
+}
+
+post_install() {
+ mhwd-gpu --check
+}
+
+post_upgrade() {
+ mhwd-gpu --check
+}
+
+
+post_remove() {
+ mhwd-gpu --check
+}