summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2018-09-22 12:16:55 -0500
committerfrealgagu2018-09-22 12:16:55 -0500
commit340abb0d0312774b224fcecdf93d8547d0d4c34c (patch)
treef97e121634e141aa839502ae112584288627ac41
parentc86e771ab066ef4a5a98ae9c0e3f452fe812a60b (diff)
downloadaur-340abb0d0312774b224fcecdf93d8547d0d4c34c.tar.gz
Retrieving submodules in sources
-rw-r--r--.SRCINFO58
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD101
3 files changed, 166 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fa211334d16..7e6e54ef5669 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,67 @@
pkgbase = micro
pkgdesc = A modern and intuitive terminal-based text editor
pkgver = 1.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zyedidia/micro
- arch = x86_64
- arch = i686
arch = armv6h
arch = armv7h
+ arch = i686
+ arch = x86_64
license = MIT
makedepends = git
makedepends = go
+ depends = glibc
optdepends = xclip: Required for copying/pasting text
- conflicts = micro-git
+ source = micro-1.4.1::git+https://github.com/zyedidia/micro.git#tag=v1.4.1
+ source = semver::git+https://github.com/blang/semver
+ source = go-humanize::git+https://github.com/dustin/go-humanize
+ source = errors::git+https://github.com/go-errors/errors
+ source = go-isatty::git+https://github.com/mattn/go-isatty
+ source = go-runewidth::git+https://github.com/mattn/go-runewidth
+ source = go-homedir::git+https://github.com/mitchellh/go-homedir
+ source = go-diff::git+https://github.com/sergi/go-diff
+ source = gopher-lua::git+https://github.com/yuin/gopher-lua
+ source = net::git+https://go.googlesource.com/net
+ source = clipboard::git+https://github.com/zyedidia/clipboard
+ source = glob::git+https://github.com/zyedidia/glob
+ source = tcell::git+https://github.com/zyedidia/tcell
+ source = encoding::git+https://github.com/gdamore/encoding
+ source = text::git+https://go.googlesource.com/text
+ source = go-colorful::git+https://github.com/lucasb-eyer/go-colorful
+ source = gopher-luar::git+https://github.com/layeh/gopher-luar
+ source = yaml.v2::git+https://gopkg.in/yaml.v2
+ source = poller::git+https://github.com/zyedidia/poller
+ source = json5::git+https://github.com/flynn/json5
+ source = terminal::git+https://github.com/zyedidia/terminal
+ source = pty::git+https://github.com/zyedidia/pty
+ source = goconvey::git+https://github.com/smartystreets/goconvey
+ source = gls::git+https://github.com/jtolds/gls
+ source = assertions::git+https://github.com/smartystreets/assertions
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = micro
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1844f05623
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,28 @@
+assertions/
+clipboard/
+encoding/
+errors/
+glob/
+gls/
+go-colorful/
+go-diff/
+go-homedir/
+go-humanize/
+go-isatty/
+go-runewidth/
+goconvey/
+gopher-lua/
+gopher-luar/
+json5/
+micro-*.pkg.tar.xz
+micro-*/
+net/
+pkg/
+poller/
+pty/
+semver/
+src/
+tcell/
+terminal/
+text/
+yaml.v2/
diff --git a/PKGBUILD b/PKGBUILD
index 0da6bbd259cf..f867a8706f8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,100 @@
-# Maintainer: Youngbin Han <sukso96100@gmail.com>
+# Maintainer: Fredy GarcĂ­a <frealgagu at gmail dot com>
+# Contributor: Youngbin Han <sukso96100@gmail.com>
# Contributor: blainester <theblainestory@gmail.com>
# Contributor: mar77i <mar77i at protonmail dot ch>
+
pkgname=micro
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and intuitive terminal-based text editor"
-arch=('x86_64' 'i686' 'armv6h' 'armv7h')
-url="https://github.com/zyedidia/micro"
-license=('MIT')
+arch=("armv6h" "armv7h" "i686" "x86_64")
+url="https://github.com/zyedidia/${pkgname}"
+license=("MIT")
+depends=("glibc")
makedepends=("git" "go")
optdepends=('xclip: Required for copying/pasting text')
-conflicts=("micro-git")
-_giturl=github.com/zyedidia/micro
+source=("${pkgname}-${pkgver}::git+https://github.com/zyedidia/${pkgname}.git#tag=v1.4.1"
+ "semver::git+https://github.com/blang/semver"
+ "go-humanize::git+https://github.com/dustin/go-humanize"
+ "errors::git+https://github.com/go-errors/errors"
+ "go-isatty::git+https://github.com/mattn/go-isatty"
+ "go-runewidth::git+https://github.com/mattn/go-runewidth"
+ "go-homedir::git+https://github.com/mitchellh/go-homedir"
+ "go-diff::git+https://github.com/sergi/go-diff"
+ "gopher-lua::git+https://github.com/yuin/gopher-lua"
+ "net::git+https://go.googlesource.com/net"
+ "clipboard::git+https://github.com/zyedidia/clipboard"
+ "glob::git+https://github.com/zyedidia/glob"
+ "tcell::git+https://github.com/zyedidia/tcell"
+ "encoding::git+https://github.com/gdamore/encoding"
+ "text::git+https://go.googlesource.com/text"
+ "go-colorful::git+https://github.com/lucasb-eyer/go-colorful"
+ "gopher-luar::git+https://github.com/layeh/gopher-luar"
+ "yaml.v2::git+https://gopkg.in/yaml.v2"
+ "poller::git+https://github.com/zyedidia/poller"
+ "json5::git+https://github.com/flynn/json5"
+ "terminal::git+https://github.com/zyedidia/terminal"
+ "pty::git+https://github.com/zyedidia/pty"
+ "goconvey::git+https://github.com/smartystreets/goconvey"
+ "gls::git+https://github.com/jtolds/gls"
+ "assertions::git+https://github.com/smartystreets/assertions")
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP"
+ "SKIP" "SKIP" "SKIP" "SKIP" "SKIP")
prepare() {
- export GOPATH="${srcdir}"
- go get -v -d "${_giturl}/..."
- cd "${GOPATH}/src/${_giturl}"
- git checkout "tags/v${pkgver}"
- sed -r -i 's/^(build:).*$/\1/' Makefile
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ git submodule init
+ git config submodule.cmd/micro/vendor/github.com/blang/semver.url "${srcdir}/semver"
+ git config submodule.cmd/micro/vendor/github.com/dustin/go-humanize.url "${srcdir}/go-humanize"
+ git config submodule.cmd/micro/vendor/github.com/go-errors/errors.url "${srcdir}/errors"
+ git config submodule.cmd/micro/vendor/github.com/mattn/go-isatty.url "${srcdir}/go-isatty"
+ git config submodule.cmd/micro/vendor/github.com/mattn/go-runewidth.url "${srcdir}/go-runewidth"
+ git config submodule.cmd/micro/vendor/github.com/mitchellh/go-homedir.url "${srcdir}/go-homedir"
+ git config submodule.cmd/micro/vendor/github.com/sergi/go-diff.url "${srcdir}/go-diff"
+ git config submodule.cmd/micro/vendor/github.com/yuin/gopher-lua.url "${srcdir}/gopher-lua"
+ git config submodule.cmd/micro/vendor/golang.org/x/net.url "${srcdir}/net"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/clipboard.url "${srcdir}/clipboard"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/glob.url "${srcdir}/glob"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/tcell.url "${srcdir}/tcell"
+ git config submodule.cmd/micro/vendor/github.com/gdamore/encoding.url "${srcdir}/encoding"
+ git config submodule.cmd/micro/vendor/golang.org/x/text.url "${srcdir}/text"
+ git config submodule.cmd/micro/vendor/github.com/lucasb-eyer/go-colorful.url "${srcdir}/go-colorful"
+ git config submodule.cmd/micro/vendor/layeh.com/gopher-luar.url "${srcdir}/gopher-luar"
+ git config submodule.cmd/micro/vendor/gopkg.in/yaml.v2.url "${srcdir}/yaml.v2"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/poller.url "${srcdir}/poller"
+ git config submodule.cmd/micro/vendor/github.com/flynn/json5.url "${srcdir}/json5"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/terminal.url "${srcdir}/terminal"
+ git config submodule.cmd/micro/vendor/github.com/zyedidia/pty.url "${srcdir}/pty"
+ git config submodule.cmd/micro/vendor/github.com/smartystreets/goconvey.url "${srcdir}/goconvey"
+ git config submodule.cmd/micro/vendor/github.com/jtolds/gls.url "${srcdir}/gls"
+ git config submodule.cmd/micro/vendor/github.com/smartystreets/assertions.url "${srcdir}/assertions"
+
+ git submodule update --init
}
build() {
- cd "${GOPATH}/src/${_giturl}"
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ echo "Linking to repository path..."
+ mkdir -p "${srcdir}/src/github.com/zyedidia"
+ ln -s "${srcdir}/${pkgname}-${pkgver}" "${srcdir}/src/github.com/zyedidia/${pkgname}"
+ cd "${srcdir}/src/github.com/zyedidia/${pkgname}"
+
+ GOPATH="${srcdir}" PATH="${PATH}:${GOPATH}/bin" make build-quick
+
+ echo "Removing link..."
+ rm -rf "${srcdir}/src"
}
package() {
- cd "${GOPATH}/src/${_giturl}"
- install -Dm755 "./micro" "${pkgdir}/usr/bin/micro"
- install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ for _file in ${srcdir}/${pkgname}-${pkgver}/*.md
+ do
+ install -Dm644 "${_file}" "${pkgdir}/usr/share/doc/${pkgname}/$(basename ${_file})"
+ done
}