summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2017-12-16 22:52:55 +0100
committermar77i2017-12-16 22:52:55 +0100
commit714f289429a317ee2266abc3559604f7c0652b9b (patch)
treea3a5713b619c9842a00faf512d678baf9dad40fd
parentdf9d240513d7a0f8001368e54754806e5f8bfcd6 (diff)
downloadaur-714f289429a317ee2266abc3559604f7c0652b9b.tar.gz
what a mess. packaging the latest release that builds, as labeled
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f726c736ae7b..023574be10df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = micro
pkgdesc = A modern and intuitive terminal-based text editor
- pkgver = 1.3.4
+ pkgver = 1.3.3
pkgrel = 5
url = https://github.com/zyedidia/micro
arch = x86_64
@@ -9,8 +9,6 @@ pkgbase = micro
depends = go
optdepends = xclip: Required for copying/pasting text
conflicts = micro-git
- source = https://github.com/zyedidia/micro/archive/v1.3.4.tar.gz
- sha256sums = SKIP
pkgname = micro
diff --git a/PKGBUILD b/PKGBUILD
index a240ccf96f46..6e319127df32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: blainester <theblainestory@gmail.com>
# Contributor: mar77i <mar77i at protonmail dot ch>
pkgname=micro
-pkgver=1.3.4
+pkgver=1.3.3
pkgrel=5
pkgdesc="A modern and intuitive terminal-based text editor"
arch=('x86_64' 'i686')
@@ -11,23 +11,23 @@ license=('MIT')
depends=("go")
optdepends=('xclip: Required for copying/pasting text')
conflicts=("micro-git")
+_giturl=github.com/zyedidia/micro
-source=("https://github.com/zyedidia/$pkgname/archive/v$pkgver.tar.gz")
-
-sha256sums=('SKIP')
+prepare() {
+ export GOPATH="${srcdir}"
+ go get -v -d "${_giturl}/..."
+ cd "${GOPATH}/src/${_giturl}"
+ git checkout "tags/v${pkgver}"
+ sed -r -i 's/^(build:).*$/\1/' Makefile
+}
build() {
- export GOPATH="$srcdir"
- mkdir -p "src/github.com/zyedidia"
- mv "${pkgname}-${pkgver}" "src/github.com/zyedidia/micro"
- cd "${srcdir}/src/github.com/zyedidia"
- go get -x -v ./...
- sed -r -i 's/^(build:).*$/\1/' Makefile
+ cd "${GOPATH}/src/${_giturl}"
make
}
package() {
- cd "${srcdir}/src/github.com/zyedidia"
- install -Dm755 "${srcdir}/${pkgname}-${pkgver}/micro" "${pkgdir}/usr/bin/micro"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ cd "${GOPATH}/src/${_giturl}"
+ install -Dm755 "./micro" "${pkgdir}/usr/bin/micro"
+ install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}