summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2017-12-16 13:52:31 +0100
committermar77i2017-12-16 13:52:31 +0100
commitdf9d240513d7a0f8001368e54754806e5f8bfcd6 (patch)
treed05b555f6354faddaad4895f1bef3ed5f7a80e55
parentbb44737edd931bef9797dd3fadd6a3c6333e27e8 (diff)
downloadaur-df9d240513d7a0f8001368e54754806e5f8bfcd6.tar.gz
try to compile from release tarball, as is the intention of this package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD49
2 files changed, 35 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8731b243eb5..f726c736ae7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,16 @@
pkgbase = micro
- pkgdesc = This package is deprecated
- pkgver = 1.3.3
- pkgrel = 4
+ pkgdesc = A modern and intuitive terminal-based text editor
+ pkgver = 1.3.4
+ pkgrel = 5
url = https://github.com/zyedidia/micro
+ arch = x86_64
+ arch = i686
license = MIT
+ depends = go
+ optdepends = xclip: Required for copying/pasting text
+ conflicts = micro-git
+ source = https://github.com/zyedidia/micro/archive/v1.3.4.tar.gz
+ sha256sums = SKIP
pkgname = micro
diff --git a/PKGBUILD b/PKGBUILD
index cd642eda8c16..a240ccf96f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
-# THIS IS AN OLD PKBUILD OF DEPRECATED PACKAGE, FEEL FREE TO CHANGE IT IF YOU"D LIKE TO MAINTAIN IT
-# PACKAGE SHOULD BE BUILT FROM SOURCE UNDER THIS NAME
# Maintainer: Youngbin Han <sukso96100@gmail.com>
# Contributor: blainester <theblainestory@gmail.com>
-# Contributor: nycko123 <email address unknown>
+# Contributor: mar77i <mar77i at protonmail dot ch>
pkgname=micro
-pkgver=1.3.3
-pkgrel=4
-pkgdesc="This package is deprecated"
-#arch=('')
+pkgver=1.3.4
+pkgrel=5
+pkgdesc="A modern and intuitive terminal-based text editor"
+arch=('x86_64' 'i686')
url="https://github.com/zyedidia/micro"
license=('MIT')
-#optdepends=('xclip: Required for copying/pasting text')
-#conflicts=('micro-git' 'micro-bin' 'micro-nightly-bin')
+depends=("go")
+optdepends=('xclip: Required for copying/pasting text')
+conflicts=("micro-git")
-#source_x86_64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux64.tar.gz")
-#source_i686=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux32.tar.gz")
+source=("https://github.com/zyedidia/$pkgname/archive/v$pkgver.tar.gz")
-#sha256sums_x86_64=('329f746e4ee9edf244618dda4208b638fda34c593d5cd96d8f71dc3b53e3d994')
-#sha256sums_i686=('7600666ae08a878c40efa2448fce03a042a18132a2a7f27e134502d36065193d')
+sha256sums=('SKIP')
-#package(){
- #install -Dm755 "${srcdir}/${pkgname}-${pkgver}/micro" "${pkgdir}/usr/bin/micro"
- #install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-#}
-echo "-------------------------------------------------"
-echo "********** This package is deprecated. **********"
-echo "* This package is getting merged into micro-bin *"
-echo "* so it's not usable anymore. *"
-echo "* Install micro-bin package if you want to use *"
-echo "* this editor. *"
-echo "-------------------------------------------------"
+build() {
+ export GOPATH="$srcdir"
+ mkdir -p "src/github.com/zyedidia"
+ mv "${pkgname}-${pkgver}" "src/github.com/zyedidia/micro"
+ cd "${srcdir}/src/github.com/zyedidia"
+ go get -x -v ./...
+ sed -r -i 's/^(build:).*$/\1/' Makefile
+ make
+}
+
+package() {
+ cd "${srcdir}/src/github.com/zyedidia"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/micro" "${pkgdir}/usr/bin/micro"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}