summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornycko1232020-06-22 16:47:43 +0200
committernycko1232020-06-22 16:47:43 +0200
commit2ce752a57b325939a4da91eed5af3b59739762bd (patch)
tree50d941779dceac14cb9a92306d1992c85c9b7237
parentbe7dbba47dac10541732afbb47f0dee7827897fd (diff)
downloadaur-2ce752a57b325939a4da91eed5af3b59739762bd.tar.gz
added .desktop and manpage (requested by https://aur.archlinux.org/account/caltlgin/)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 25 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f1fbf4b79a0..11d9de7ef8a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = micro-bin
pkgdesc = A modern and intuitive terminal-based text editor
pkgver = 2.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/zyedidia/micro
arch = x86_64
arch = i686
@@ -12,9 +12,17 @@ pkgbase = micro-bin
conflicts = micro
conflicts = micro-nightly-bin
source_x86_64 = https://github.com/zyedidia/micro/releases/download/v2.0.5/micro-2.0.5-linux64.tar.gz
+ source_x86_64 = https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.1
+ source_x86_64 = https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.desktop
sha256sums_x86_64 = 4f159a4b8a08c48559bd94b3aacdca9a6188af0f9919fec61e01dde44f0f4fa0
+ sha256sums_x86_64 = e753edc9899152ab1c70926b8f096d0bdcd1efa9213dd27fcef2e0b85236153e
+ sha256sums_x86_64 = 3fd83fda3c2a6711edbc5e4158db5ba0898e8b59760d30f8e3bce7642e071be7
source_i686 = https://github.com/zyedidia/micro/releases/download/v2.0.5/micro-2.0.5-linux32.tar.gz
+ source_i686 = https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.1
+ source_i686 = https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.desktop
sha256sums_i686 = 6b60ca069e9b28d1d8ddb3d70a191bab8a588b5eb8903b1fab794789521bf37d
+ sha256sums_i686 = e753edc9899152ab1c70926b8f096d0bdcd1efa9213dd27fcef2e0b85236153e
+ sha256sums_i686 = 3fd83fda3c2a6711edbc5e4158db5ba0898e8b59760d30f8e3bce7642e071be7
pkgname = micro-bin
diff --git a/PKGBUILD b/PKGBUILD
index a6b5b417d197..bc2227f1cd4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Previous Contributor: blainester <theblainestory at gmail com>
pkgname=micro-bin
pkgver=2.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="A modern and intuitive terminal-based text editor"
arch=('x86_64' 'i686')
url="https://github.com/zyedidia/micro"
@@ -14,16 +14,27 @@ optdepends=('xclip: Required for copying/pasting text')
conflicts=('micro-git' 'micro' 'micro-nightly-bin')
provides=('micro')
-source_x86_64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux64.tar.gz")
-source_i686=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux32.tar.gz")
+source_x86_64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux64.tar.gz"
+ "https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.1"
+ "https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.desktop")
+source_i686=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux32.tar.gz"
+ "https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.1"
+ "https://raw.githubusercontent.com/zyedidia/micro/master/assets/packaging/micro.desktop")
-sha256sums_x86_64=('4f159a4b8a08c48559bd94b3aacdca9a6188af0f9919fec61e01dde44f0f4fa0')
-sha256sums_i686=('6b60ca069e9b28d1d8ddb3d70a191bab8a588b5eb8903b1fab794789521bf37d')
+sha256sums_x86_64=('4f159a4b8a08c48559bd94b3aacdca9a6188af0f9919fec61e01dde44f0f4fa0'
+ 'e753edc9899152ab1c70926b8f096d0bdcd1efa9213dd27fcef2e0b85236153e'
+ '3fd83fda3c2a6711edbc5e4158db5ba0898e8b59760d30f8e3bce7642e071be7')
+sha256sums_i686=('6b60ca069e9b28d1d8ddb3d70a191bab8a588b5eb8903b1fab794789521bf37d'
+ 'e753edc9899152ab1c70926b8f096d0bdcd1efa9213dd27fcef2e0b85236153e'
+ '3fd83fda3c2a6711edbc5e4158db5ba0898e8b59760d30f8e3bce7642e071be7')
package(){
install -Dm755 "${srcdir}/${pkgname%-*}-${pkgver}/${pkgname%-*}" "${pkgdir}/usr/bin/${pkgname%-*}"
install -Dm644 "${srcdir}/${pkgname%-*}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-*}/LICENSE"
+ install -Dm644 "${srcdir}/${pkgname%-*}-${pkgver}/LICENSE-THIRD-PARTY" "${pkgdir}/usr/share/licenses/${pkgname%-*}/LICENSE-THIRD-PARTY"
for _file in "${srcdir}/${pkgname%-*}-${pkgver}/"*.md; do
install -Dm644 "${_file}" "${pkgdir}/usr/share/doc/${pkgname%-*}/$(basename ${_file})"
done
+ install -Dm644 "${srcdir}/micro.1" "${pkgdir}/usr/share/man/man1/micro.1"
+ install -Dm644 "${srcdir}/micro.desktop" "${pkgdir}/usr/share/applications/micro.desktop"
}