summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornycko1232020-10-07 16:59:53 +0200
committernycko1232020-10-07 16:59:53 +0200
commit7b6c7d4946bed2721e9ff45495046b0bce751376 (patch)
tree096b35bc5a404d7714aecaa2d22ee1c118ea6f72
parent813672d5b92636090772b187e6a0d9f9bb55d1db (diff)
downloadaur-7b6c7d4946bed2721e9ff45495046b0bce751376.tar.gz
2.0.8 - added aarch64
-rw-r--r--.SRCINFO15
-rw-r--r--CHANGELOG9
-rw-r--r--PKGBUILD12
3 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a810767c41e..7f1845d3f9f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,24 @@
pkgbase = micro-bin
pkgdesc = A modern and intuitive terminal-based text editor
- pkgver = 2.0.7
- pkgrel = 2
+ pkgver = 2.0.8
+ pkgrel = 1
url = https://github.com/zyedidia/micro
changelog = CHANGELOG
arch = x86_64
arch = i686
+ arch = aarch64
license = MIT
optdepends = xclip: Required for copying/pasting text
provides = micro
conflicts = micro-git
conflicts = micro
conflicts = micro-nightly-bin
- source_x86_64 = https://github.com/zyedidia/micro/releases/download/v2.0.7/micro-2.0.7-linux64.tar.gz
- sha256sums_x86_64 = 843b8ffa6e10cb0fb67bae5047af496a0c13d3ac678df0fb44b5ec00eca62615
- source_i686 = https://github.com/zyedidia/micro/releases/download/v2.0.7/micro-2.0.7-linux32.tar.gz
- sha256sums_i686 = a093c18ff48c5cf9103e546e43efdc6c31375ee7028b88f434686c7e1d9aaeb2
+ source_x86_64 = https://github.com/zyedidia/micro/releases/download/v2.0.8/micro-2.0.8-linux64.tar.gz
+ sha256sums_x86_64 = 7a705a60fe5da8fdfbb1423b560ae120a59af963ec73e3548ef97a6a688cd7cf
+ source_i686 = https://github.com/zyedidia/micro/releases/download/v2.0.8/micro-2.0.8-linux32.tar.gz
+ sha256sums_i686 = 7b81d1f54ba708295c86e363fa6350e30109249e7d144d3a7d3b5cfa7b861dcc
+ source_aarch64 = https://github.com/zyedidia/micro/releases/download/v2.0.8/micro-2.0.8-linux-arm64.tar.gz
+ sha256sums_aarch64 = c39f49432e4e93c46a21c20bfc250fa2cf7a4dfb01af6d3684b3c45f0ed7c240
pkgname = micro-bin
diff --git a/CHANGELOG b/CHANGELOG
index f9a8732250b9..d161fafa64a4 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -392,3 +392,12 @@
Fix path escaping on Windows.
Fix issue when fastdirty is off
Syntax highlighting and linting fixes
+
+2.0.8 (6 Oct 2020)
+ Terminfo fixes
+ Mouse mode in alacritty and konsole fixed.
+ Modifier key detection for dynamic terminals fixed.
+ Background color in terminal emulator fixed.
+ Syntax highlighting improvements
+ C++, Crystal, Groovy, Coffeescript.
+ Parentheses no longer highlighted in default theme (makes the colors less jarring and more consistent with other themes).
diff --git a/PKGBUILD b/PKGBUILD
index daf192edf640..a80bb3f3b80a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@
# Previous Maintainer (27.04.2016 - 15.10.2017): Youngbin Han <sukso96100 at gmail com>
# Previous Contributor: blainester <theblainestory at gmail com>
pkgname=micro-bin
-pkgver=2.0.7
-pkgrel=2
+pkgver=2.0.8
+pkgrel=1
pkgdesc="A modern and intuitive terminal-based text editor"
-arch=('x86_64' 'i686')
+arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/zyedidia/micro"
license=('MIT')
optdepends=('xclip: Required for copying/pasting text')
@@ -17,9 +17,11 @@ changelog="CHANGELOG"
source_x86_64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux64.tar.gz")
source_i686=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux32.tar.gz")
+source_aarch64=("https://github.com/zyedidia/micro/releases/download/v${pkgver}/micro-${pkgver}-linux-arm64.tar.gz")
-sha256sums_x86_64=('843b8ffa6e10cb0fb67bae5047af496a0c13d3ac678df0fb44b5ec00eca62615')
-sha256sums_i686=('a093c18ff48c5cf9103e546e43efdc6c31375ee7028b88f434686c7e1d9aaeb2')
+sha256sums_x86_64=('7a705a60fe5da8fdfbb1423b560ae120a59af963ec73e3548ef97a6a688cd7cf')
+sha256sums_i686=('7b81d1f54ba708295c86e363fa6350e30109249e7d144d3a7d3b5cfa7b861dcc')
+sha256sums_aarch64=('c39f49432e4e93c46a21c20bfc250fa2cf7a4dfb01af6d3684b3c45f0ed7c240')
package(){
install -Dm755 "${srcdir}/${pkgname%-*}-${pkgver}/${pkgname%-*}" "${pkgdir}/usr/bin/${pkgname%-*}"