summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreyson Christoforo2021-02-06 20:48:39 +0000
committerGreyson Christoforo2021-02-06 20:48:39 +0000
commit9be2fde08b13c5c72d396b6e67770a57b3292237 (patch)
tree49df47b55b456e97b925240765b2ab545b68f0f7
downloadaur-9be2fde08b13c5c72d396b6e67770a57b3292237.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore3
-rw-r--r--LICENSE12
-rw-r--r--PKGBUILD48
-rw-r--r--launcher12
-rw-r--r--setup.iss.tarbin0 -> 10240 bytes
6 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78ddaf2a7988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = micro-cap
+ pkgdesc = an integrated schematic editor and mixed analog/digital circuit simulator
+ pkgver = 12
+ pkgrel = 1
+ epoch = 0
+ url = http://www.spectrum-soft.com/index.shtm
+ arch = x86_64
+ license = custom
+ depends = wine
+ depends = wine-gecko
+ depends = wine-mono
+ source = micro-cap-12.zip::http://www.spectrum-soft.com/download/mc12cd.zip
+ source = launcher
+ source = setup.iss.tar
+ source = LICENSE
+ sha256sums = f4fda36ae96ab618c0487b2ff199b37bb8b12a26ecabc2ef11c6d36a5bac02a7
+ sha256sums = d4d5d2ce22691a8668ad5071c57f860e686b061142f8c9bd4cefe01df5f3c87f
+ sha256sums = d51262c700c2e860bbb8d6d9c0cacc424ba4a60edd299ce20b46367cc078fbbf
+ sha256sums = 350a5c1fe63617959e971db8f3f97a694b251fefee296c88fcbd939d3ec90f63
+
+pkgname = micro-cap
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1dc327437eb7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.zip
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1b89d398ba03
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,12 @@
+AS DISPLAYED TO THE USER BY THE GRAPHICAL INSTALLER:
+Micro-Cap License Agreement and Disclaimer
+
+Micro-Cap is Spectrum Software's circuit simulation software. As of 7/4/2019, it is available free to the entire engineering community.
+
+This software is copyrighted. You are granted a non-exclusive, non-transferable, non-sublicenseable, royalty-free right to perform general circuit simulation.
+
+While we have made every effort to ensure that Micro-Cap operates in the manner described, we do not guarantee operation to be error free. Upgrades, modifications, or repairs to this program will be strictly at the discretion of Spectrum Software.
+
+The software and related documentation are provided "AS IS" and without warranty of any kind. Spectrum Software expressly disclaims all other warranties, express or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Under no circumstances will Spectrum Software be liable for damages, either direct or consequential, arising from the use of this product or from the inability to use this product, even if we have been informed in advance of the possibility of such damages.
+
+Redistribution of this software is permitted as long as it is distributed in its entirety, with all documentation, sample circuit files, and models without modification or additions.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c54ae695bcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgname=micro-cap
+pkgver=12
+pkgrel=1
+epoch=0
+pkgdesc='an integrated schematic editor and mixed analog/digital circuit simulator'
+arch=(x86_64)
+url='http://www.spectrum-soft.com/index.shtm'
+license=('custom')
+depends=(
+wine
+wine-gecko
+wine-mono
+)
+
+# archived at https://web.archive.org/web/20201107223859/http://www.spectrum-soft.com/download/mc12cd.zip
+source=("${pkgname}-${pkgver}.zip::http://www.spectrum-soft.com/download/mc${pkgver}cd.zip" launcher setup.iss.tar LICENSE)
+sha256sums=('f4fda36ae96ab618c0487b2ff199b37bb8b12a26ecabc2ef11c6d36a5bac02a7'
+ 'd4d5d2ce22691a8668ad5071c57f860e686b061142f8c9bd4cefe01df5f3c87f'
+ 'd51262c700c2e860bbb8d6d9c0cacc424ba4a60edd299ce20b46367cc078fbbf'
+ '350a5c1fe63617959e971db8f3f97a694b251fefee296c88fcbd939d3ec90f63')
+
+build(){
+ install -m755 -d tmp tmp/env tmp/local
+ export WINEPREFIX="${srcdir}/"tmp/env
+ export XDG_DATA_HOME="${srcdir}"/tmp/local
+ wineboot -u
+
+ cp setup.iss tmp/env/drive_c
+ WINEDEBUG=-all wine "$srcdir"/setup.exe /SMS /s /f1"C:\setup.iss"
+}
+
+package() {
+ cp launcher micro-cap
+ chmod +x micro-cap
+ install -m755 -Dt "${pkgdir}"/usr/bin micro-cap
+
+ rm micro-cap
+ rm launcher
+ rm ${pkgname}-${pkgver}.zip
+
+ install -d -m755 "${pkgdir}"/usr/share/micro-cap/
+ cp -a "${srcdir}/"tmp/env "${pkgdir}"/usr/share/micro-cap
+ cp -a "${srcdir}/"tmp/local "${pkgdir}"/usr/share/micro-cap
+
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}
diff --git a/launcher b/launcher
new file mode 100644
index 000000000000..5aae71eb04c7
--- /dev/null
+++ b/launcher
@@ -0,0 +1,12 @@
+#!/bin/bash
+export XDG_DATA_HOME="$HOME"/.micro-cap/wine/local
+if [ ! -d "$HOME"/.micro-cap/wine/local ] ; then
+ mkdir -p "$HOME"/.micro-cap/wine
+ cp -a /usr/share/micro-cap/local "$HOME"/.micro-cap/wine
+fi
+export WINEPREFIX="$HOME"/.micro-cap/wine/env
+if [ ! -d "$HOME"/.micro-cap/wine/env ] ; then
+ mkdir -p "$HOME"/.micro-cap/wine
+ cp -a /usr/share/micro-cap/env "$HOME"/.micro-cap/wine
+fi
+WINEDEBUG=-all wine64 "C:\\MC12\\mc12_64.exe" "$@"
diff --git a/setup.iss.tar b/setup.iss.tar
new file mode 100644
index 000000000000..de4c29586050
--- /dev/null
+++ b/setup.iss.tar
Binary files differ