summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukso961002016-09-03 15:25:53 +0900
committersukso961002016-09-03 15:25:53 +0900
commitaed1c2a2c6b45988c98ece060466a53db17cc39d (patch)
tree0005c23d7106f9312319a45264e4aca08fd11612
parent097ffcaa2341c5bc240e89f248da720888676714 (diff)
downloadaur-aed1c2a2c6b45988c98ece060466a53db17cc39d.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c534f20d472..3d55467c7c83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Aug 8 05:26:02 UTC 2016
+# Sat Sep 3 06:25:41 UTC 2016
pkgbase = micro-git
pkgdesc = A modern and intuitive terminal-based text editor
- pkgver = 5da6b31
+ pkgver = 1.0.1.1c2b815
pkgrel = 1
url = https://github.com/zyedidia/micro
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = micro-git
license = MIT
makedepends = go
makedepends = git
- optdepends = xclip
+ depends = xclip
conflicts = micro
source = micro-git::git+https://github.com/zyedidia/micro.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 439ad274cc64..4919de9e692c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Youngbin Han <sukso96100@gmail.com>
pkgname=micro-git
-pkgver=5da6b31
+pkgver=1.0.1.1c2b815
pkgrel=1
pkgdesc="A modern and intuitive terminal-based text editor"
arch=('x86_64' 'i686')
url="https://github.com/zyedidia/micro"
license=('MIT')
makedepends=('go' 'git')
-optdepends=(xclip)
+depends=(xclip)
conflicts=("micro")
source=("${pkgname}"::"git+https://github.com/zyedidia/micro.git")
md5sums=(SKIP)
pkgver() {
cd "${srcdir}/${pkgname}"
- echo "$(git rev-parse --short HEAD)"
+ echo "$(git tag | sort -V | tail -1).$(git rev-parse --short HEAD)"
}
build(){
cd "${srcdir}/${pkgname}"