summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfoxido2022-12-18 23:53:08 +0300
committerfoxido2022-12-18 23:53:08 +0300
commit6f5d0da3d523781e77b8cf64baea78da96d30610 (patch)
treef8ba47a69dfdadda82354bcd394d8814eff4797d
parent6dc419ea8e6aa89c859efd12a381dd7cfda04c67 (diff)
downloadaur-6f5d0da3d523781e77b8cf64baea78da96d30610.tar.gz
Fix PKGBUILD issues. Thanks @kseistrup
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eecd13355b7..46e3d8e02fd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,10 +3,17 @@ pkgbase = microbin
pkgver = 1.2.0
pkgrel = 1
url = https://github.com/szabodanika/microbin
- arch = any
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
license = BSD
checkdepends = cargo
makedepends = cargo
+ options = !lto
backup = etc/microbin.conf
source = https://github.com/szabodanika/microbin/archive/refs/tags/v1.2.0.tar.gz
source = microbin.service
diff --git a/PKGBUILD b/PKGBUILD
index b9a644540c14..8f020f30b933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=microbin
pkgver=1.2.0
pkgrel=1
pkgdesc="A tiny, self-contained, configurable paste bin and URL shortener written in Rust."
-arch=('any')
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/szabodanika/microbin"
license=('BSD')
makedepends=('cargo')
@@ -18,10 +18,7 @@ sha256sums=('fc3e9b13814c3f43c7ef57029f7118a35ac49f6ad984da9b081c1a8ce945f8f7'
'8e943fc702637b1b7441491db945c078d190c4208cd202e5e360cad90ca793ab')
-#prepare() {
-# cd "$srcdir/$pkgname-$pkgver"
-# cargo fetch
-#}
+options=(!lto)
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -29,11 +26,6 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
- ## Disable lto
- export CFLAGS=`echo $CFLAGS | sed 's/-flto//g'`
- export CXXFLAGS=`echo $CXXFLAGS | sed 's/-flto//g'`
- export LDFLAGS=`echo $LDFLAGS | sed 's/-flto//g'`
-
cargo build --release
}