summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Campos Las Heras2020-03-14 07:23:07 -0300
committerRafael Campos Las Heras2020-03-14 08:08:53 -0300
commita6c476257ced48e10d81ae5426001556a9b164c7 (patch)
tree25c5cb7c1ce29e1a7dde4786f2f976c60db20812
parent269948f49c949c55770d999fa61c7f7ce86ed3d6 (diff)
downloadaur-a6c476257ced48e10d81ae5426001556a9b164c7.tar.gz
Version bump to 1.50
Version bump to 1.50 This version is 64bits only, so some dependencies had change (tclkit dependency is 64 bit and conflicts with lib32-tclkit). Upgrade the sums to sha256 (checksums provided by Microhip). Added new dependency lib32-expat as requested by dTeubl).
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a77007a240e..3533ab5ef782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = microchip-mplabxc16-bin
pkgdesc = Microchip's MPLAB XC16 C compiler toolchain for their dsPIC and PIC24 microcontroller families
- pkgver = 1.41
+ pkgver = 1.50
pkgrel = 1
url = http://www.microchip.com/xc16
install = microchip-mplabxc16-bin.install
@@ -14,13 +14,13 @@ pkgbase = microchip-mplabxc16-bin
options = emptydirs
options = !zipman
options = staticlibs
- source = http://ww1.microchip.com/downloads/en/DeviceDoc/xc16-v1.41-full-install-linux-installer.run
+ source = http://ww1.microchip.com/downloads/en/DeviceDoc/xc16-v1.50-full-install-linux64-installer.run
source = bitrock-unpacker.tcl
- md5sums = 98e2a50d75bdb0164b0c4cd82d1d6c74
- md5sums = 70dedba4c417f8c0bb07c32d19e9d197
+ sha256sums = 693f4c30c25701561d708a7ab984200b37e296597fffa680b3848a86cb534c02
+ sha256sums = 1bcb58cdbb6e4a89415cf91cb6692aa0ada3abb41d22134510f8477ffd90b8a2
makedepends_i686 = tclkit
depends_x86_64 = lib32-gcc-libs
- makedepends_x86_64 = lib32-tclkit
+ makedepends_x86_64 = lib32-expat
pkgname = microchip-mplabxc16-bin
diff --git a/PKGBUILD b/PKGBUILD
index 22eec4521176..89584597be4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_number_of_bits=16
pkgname=microchip-mplabxc${_number_of_bits}-bin
-pkgver=1.41
+pkgver=1.50
pkgrel=1
pkgdesc="Microchip's MPLAB XC${_number_of_bits} C compiler toolchain for their dsPIC and PIC24 microcontroller families"
arch=(i686 x86_64)
@@ -13,14 +13,17 @@ license=(custom)
depends_i688=(gcc-libs)
depends_x86_64=(lib32-gcc-libs)
makedepends=(sdx)
-makedepends_x86_64=(lib32-tclkit)
+makedepends_x86_64=(tclkit)
makedepends_i686=(tclkit)
+makedepends_x86_64=(lib32-expat)
options=(!strip docs libtool emptydirs !zipman staticlibs)
-source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux-installer.run" "bitrock-unpacker.tcl")
+source=("http://ww1.microchip.com/downloads/en/DeviceDoc/xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run" "bitrock-unpacker.tcl")
-md5sums=('98e2a50d75bdb0164b0c4cd82d1d6c74'
- '70dedba4c417f8c0bb07c32d19e9d197')
+sha256sums=('693f4c30c25701561d708a7ab984200b37e296597fffa680b3848a86cb534c02'
+ '1bcb58cdbb6e4a89415cf91cb6692aa0ada3abb41d22134510f8477ffd90b8a2')
+#md5sums=('98e2a50d75bdb0164b0c4cd82d1d6c74'
+# '70dedba4c417f8c0bb07c32d19e9d197')
install=$pkgname.install
instdir="/opt/microchip/xc${_number_of_bits}/v${pkgver}"
@@ -29,7 +32,7 @@ PKGEXT='.pkg.tar'
build() {
msg2 "Unpacking files from installer"
- ./bitrock-unpacker.tcl ./xc${_number_of_bits}-v$pkgver-full-install-linux-installer.run ./unpacked.vfs
+ ./bitrock-unpacker.tcl ./xc${_number_of_bits}-v$pkgver-full-install-linux64-installer.run ./unpacked.vfs
}
package() {