summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-04 15:30:05 +0200
committerGrey Christoforo2015-08-04 15:30:05 +0200
commit5bcee6d0e8141aa4878d680542a1f7c89cf3a8ee (patch)
treeeacf5f4a09b651ac8fae9764647c32da2f608b0f
parent7236202adc7ef0d4dd003d003e222966f35dc965 (diff)
downloadaur-5bcee6d0e8141aa4878d680542a1f7c89cf3a8ee.tar.gz
thanks to mickael9: fixed a bug I had in reassembling the files after they were unpacked from the installer
the licence manager is now packaged
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6996686166f3..cc27935394db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = microchip-mplabxc32-bin
pkgdesc = Microchip's MPLAB XC32 C compiler toolchain for all of their 32bit microcontrollers
pkgver = 1.40
- pkgrel = 1
+ pkgrel = 2
url = http://www.microchip.com/xc32
install = microchip-mplabxc32-bin.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 7f34bbed62b0..4b0b06741ef5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_number_of_bits=32
pkgname=microchip-mplabxc${_number_of_bits}-bin
pkgver=1.40
-pkgrel=1
+pkgrel=2
pkgdesc="Microchip's MPLAB XC${_number_of_bits} C compiler toolchain for all of their 32bit microcontrollers"
arch=(i686 x86_64)
url=http://www.microchip.com/xc${_number_of_bits}
@@ -52,16 +52,16 @@ EOF
# now reassemble files larger than 5MB in the archive, which were split up for whatever reason
msg2 "Reassembling files..."
- for f in $(find ./unpacked.vfs -name '*___bitrockBigFile1')
+ find unpacked.vfs -name '*___bitrockBigFile1' | while read firstChunk
do
- firstChunk="$f"
- baseName="${firstChunk//___bitrockBigFile1/}"
- allPieces="$(find -path "${baseName}*" | sort --version-sort)"
- cat $allPieces > "$baseName".reassembled
- rm $allPieces
- mv "$baseName".reassembled "$baseName"
+ baseName="${firstChunk%%___bitrockBigFile1}"
+ local i=1
+ while [[ -f "${baseName}___bitrockBigFile${i}" ]]
+ do
+ cat "${baseName}___bitrockBigFile${i}" >> "${baseName}"
+ i=$((i + 1))
+ done
done
-
}
package() {
@@ -70,9 +70,12 @@ package() {
mkdir -p "$pkgdir"/opt/$pkgname
mv unpacked.vfs/compiler/programfiles/* "$pkgdir"/opt/$pkgname/.
+ mv unpacked.vfs/licensecomponent "$pkgdir"/opt/$pkgname/.
msg2 "Making executables executable"
find "$pkgdir"/opt/$pkgname/bin -type f -exec /bin/sh -c "file {} | grep -q executable && chmod +x {}" \;
+ chmod +x "$pkgdir"/opt/$pkgname/licensecomponent/xclmallBin/bin/xclm
+ chmod +x "$pkgdir"/opt/$pkgname/licensecomponent/LinuxLM/xclmcheck.sh
mkdir -p "$pkgdir/etc/profile.d"
echo "export PATH="'$PATH'":/opt/${pkgname}/bin" > "$pkgdir/etc/profile.d/${pkgname}.sh"