summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-06-21 13:02:07 +0200
committerGrey Christoforo2015-06-21 13:02:07 +0200
commit11c57ccf7280055726b847cc505bc92a7d11accb (patch)
tree7cdcd83a8a2b48caaa53127c517310b7db0049f3
parentef9de5b5be2dd503e12fb9fa746d565bd3193121 (diff)
downloadaur-11c57ccf7280055726b847cc505bc92a7d11accb.tar.gz
send message to user on upgrade too
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--microchip-mplabxc8-bin.install10
3 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 298e622e8904..11f4ca2871aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = microchip-mplabxc8-bin
pkgdesc = Microchip's MPLAB XC8 C compiler toolchain for their PIC10/12/16/18 microcontroller families and their PIC14000 device
pkgver = 1.34
- pkgrel = 4
+ pkgrel = 5
url = http://www.microchip.com/xc8
install = microchip-mplabxc8-bin.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index fba8557b9a58..362ddf162f90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_number_of_bits=8
pkgname=microchip-mplabxc${_number_of_bits}-bin
pkgver=1.34
-pkgrel=4
+pkgrel=5
pkgdesc="Microchip's MPLAB XC8 C compiler toolchain for their PIC10/12/16/18 microcontroller families and their PIC14000 device"
arch=(i686 x86_64)
url=http://www.microchip.com/xc${_number_of_bits}
diff --git a/microchip-mplabxc8-bin.install b/microchip-mplabxc8-bin.install
index 81d317cd7576..30b00651acb8 100644
--- a/microchip-mplabxc8-bin.install
+++ b/microchip-mplabxc8-bin.install
@@ -1,4 +1,4 @@
-post_install() {
+message_to_user(){
echo '
This package provides a file: /etc/profile.d/microchip-mplabxc8-bin.sh
It will add the toolchain binaries to the PATH variable for every user.
@@ -15,3 +15,11 @@ and enter:
$XC8_TOOLCHAIN_ROOT/bin
'
}
+
+post_install() {
+ message_to_user
+}
+
+post_upgrade() {
+ message_to_user
+}