summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorradioxoma2014-05-24 13:48:44 +0300
committerradioxoma2014-05-24 13:48:44 +0300
commit349eb46c4c1eceee555c64fc059d0265efe84c29 (patch)
tree1369700d8e38e4552ec7d52b976b7a5a94cd1758
parent6bae171ffd7489d9b7e30e84a95119f17f53eacd (diff)
downloadaur-349eb46c4c1eceee555c64fc059d0265efe84c29.tar.gz
Micromanager license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13b00eb784f..5304cdb0c241 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = micromanager-git
changelog = ChangeLog
arch = x86_64
arch = i686
- license = LGPL-2.1 BSD GPL-3
+ license = BSD LGPL
makedepends = git
makedepends = swig
depends = zlib
diff --git a/PKGBUILD b/PKGBUILD
index 139d5f1eb7e3..7dac56f4c8f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ epoch=
pkgdesc="Software package for control of automated microscopes. CMMCore and python2 bindings only."
arch=('x86_64' 'i686')
url="http://www.micro-manager.org"
-license=('LGPL-2.1 BSD GPL-3')
+license=('BSD LGPL')
groups=()
depends=('zlib' 'boost' 'libdc1394' 'python2' 'python2-numpy')
makedepends=('git' 'swig')
@@ -67,7 +67,9 @@ package() {
python2 -O -m compileall "$SPDIR"
# We need to update ldconfig cache with new libs.
- install -D -m644 "$srcdir/micromanager-lib.conf" "$pkgdir/etc/ld.so.conf.d/micromanager-lib.conf"
+ install -Dm644 "$srcdir/micromanager-lib.conf" "$pkgdir/etc/ld.so.conf.d/micromanager-lib.conf"
+
+ install -Dm644 "$srcdir/$pkgname/doc/copyright.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# This script print 'DemoCamera' property list if CMMCore and python bindings