summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryjun2022-04-30 13:35:03 +0800
committeryjun2022-04-30 13:35:03 +0800
commit7934d3feaec9ac3e9e34d05b8da2c4fe5f886b93 (patch)
tree4591242dd110d0a42c5749b2cb6f87ae574881d7
parent704cc0a4bc98f73cf7726fdd14a03dcf89ee42ec (diff)
downloadaur-micronucleus-git.tar.gz
Fixed generated wrong version from pkver()
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e43aaeb5aef..c10ada19f6b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = micronucleus-git
pkgdesc = ATTiny usb bootloader with a strong emphasis on bootloader compactness
- pkgver = 2.04.r6.g4d2481d
- pkgrel = 3
+ pkgver = 2.5.r0.gc2c7fa0
+ pkgrel = 1
url = https://github.com/micronucleus/micronucleus
arch = x86_64
arch = i686
@@ -19,4 +19,3 @@ pkgbase = micronucleus-git
sha1sums = SKIP
pkgname = micronucleus-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2a6a2ff648
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zst
+src/
+pkg/
+micronucleus
diff --git a/PKGBUILD b/PKGBUILD
index bc76d07623c2..d38fdec4d2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=micronucleus-git
_gitname=micronucleus
-pkgver=2.04.r6.g4d2481d
-pkgrel=3
+pkgver=2.5.r0.gc2c7fa0
+pkgrel=1
pkgdesc="ATTiny usb bootloader with a strong emphasis on bootloader compactness"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/micronucleus/micronucleus"
@@ -19,15 +19,16 @@ sha1sums=('SKIP')
pkgver() {
cd $_gitname
-
- git describe --tags | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ _major=$(grep -o ' [0-9].[0-9] ' commandline/library/micronucleus_lib.h | sed s/[[:space:]]//g)
+ _sub=$(git describe --long | sed 's/^master.LATEST.//;s/\([^-]*-g\)/r\1/;s/-/./g')
+ echo ${_major}.${_sub}
}
prepare() {
# Upstream set static compilation in Makefile, libusb.a is required for it.
# [Static binaries for MacOS and linux @stonehippo](https://github.com/micronucleus/micronucleus/commit/44a7664bd4c86b86596fe13bcdae7428fe1c4907)
# but Arch Linux libusb-compat package doesn't provide static library, so revert to origion
- # https://github.com/archlinux/svntogit-packages/blob/ddec4746eea5ff836dddc80b8564e3e2677f3520/libusb-compat/trunk/PKGBUILD
+ # https://github.com/archlinux/svntogit-packages/blob/packages/libusb-compat//trunk/PKGBUILD#L19
sed -i 's# -static##g' ${srcdir}/${_gitname}/commandline/Makefile
}