summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Webster2018-06-25 01:17:57 +1200
committerNick Webster2018-06-25 01:17:57 +1200
commit5a4e0b3158a883fcd68250ce51c97da175f01ef1 (patch)
tree0e11ebbbeabc3ed5c33dd8080ef340b641f100a7
downloadaur-5a4e0b3158a883fcd68250ce51c97da175f01ef1.tar.gz
Adding the initial PKGBUILD for the MicroPad Electron app
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD29
-rw-r--r--micropad.install16
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd2fc8987443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = micropad
+ pkgdesc = A powerful notepad app that respects your freedoms and runs on everything.
+ pkgver = 3.5.9
+ pkgrel = 1
+ url = https://getmicropad.com
+ install = micropad.install
+ arch = x86_64
+ license = MPL2
+ depends = c-ares
+ depends = gconf
+ depends = ffmpeg
+ depends = gtk3
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
+ depends = libxss
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ source = https://github.com/MicroPad/Electron/releases/download/v3.5.9/micropad-3.5.9.pacman
+ md5sums = 7de061e3d41038ec1a08387446338cdb
+
+pkgname = micropad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13eaecbcb214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nick Webster <nick@nick.geek.nz>
+pkgname=micropad
+pkgver=3.5.9
+pkgrel=1
+pkgdesc="A powerful notepad app that respects your freedoms and runs on everything."
+arch=('x86_64')
+url="https://getmicropad.com"
+license=('MPL2')
+depends=('c-ares'
+ 'gconf'
+ 'ffmpeg'
+ 'gtk3'
+ 'http-parser'
+ 'libevent'
+ 'libvpx'
+ 'libxslt'
+ 'libxss'
+ 'minizip'
+ 'nss'
+ 're2'
+ 'snappy')
+source=("https://github.com/MicroPad/Electron/releases/download/v${pkgver}/${pkgname}-${pkgver}.pacman")
+md5sums=('7de061e3d41038ec1a08387446338cdb')
+install="micropad.install"
+
+package() {
+ mv opt "${pkgdir}/opt"
+ mv usr "${pkgdir}/usr"
+}
diff --git a/micropad.install b/micropad.install
new file mode 100644
index 000000000000..a58809ee6d44
--- /dev/null
+++ b/micropad.install
@@ -0,0 +1,16 @@
+post_install() {
+ :
+#!/bin/bash
+
+# Link to the binary
+ln -sf '/opt/µPad/micropad' '/usr/local/bin/micropad'
+
+}
+post_remove() {
+ :
+#!/bin/bash
+
+# Delete the link to the binary
+rm -f '/usr/local/bin/micropad'
+
+}