summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2021-04-14 03:57:10 -0400
committerKyle Keen2021-04-14 03:57:10 -0400
commit1678b0e3b46d15f3d35790d92c266da0230c5141 (patch)
treef4b79007c339b4b1c597c52c5ee5fed5c1afb1a1
parent9ed35e7f5c5e7f78f354d30cec7359285e1e1761 (diff)
downloadaur-1678b0e3b46d15f3d35790d92c266da0230c5141.tar.gz
1.14, better source tarball
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 16 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 779d680ecea5..a4fd30fca579 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jan 23 07:55:59 UTC 2021
+# Wed Apr 14 07:57:06 UTC 2021
pkgbase = micropython
pkgdesc = Python3 for microcontrollers, with stdlib. (unix version)
- pkgver = 1.13
+ pkgver = 1.14
pkgrel = 1
url = http://micropython.org/
arch = i686
@@ -15,16 +15,10 @@ pkgbase = micropython
depends = libffi
depends = mbedtls
options = !emptydirs
- source = mpy-1.13.tgz::https://github.com/micropython/micropython/archive/v1.13.tar.gz
+ source = https://micropython.org/resources/source/micropython-1.14.tar.xz
source = mlib-1.9.3.tgz::https://github.com/micropython/micropython-lib/archive/v1.9.3.tar.gz
- source = axtls-1.8.2.tgz::https://github.com/pfalcon/axtls/archive/v1.8.2.tar.gz
- source = ffi-3.3.tgz::https://github.com/libffi/libffi/archive/v3.3.tar.gz
- source = bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz
- md5sums = 219d12f6017cd8a89a3c316e1c096091
+ md5sums = 5db292b2bc1758b7d7062afbe9b0db0f
md5sums = 1752ce13e851a671a07ce3f7a807b21c
- md5sums = e11da4ef04499030d1eff69b474f34f0
- md5sums = f25aefb928eed09e858878382e10641f
- md5sums = SKIP
pkgname = micropython
diff --git a/PKGBUILD b/PKGBUILD
index 899716f938ce..c2758d7a1be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
# Maintainer: Kyle Keen <keenerd@gmail.com>
pkgbase=micropython
pkgname=(micropython micropython-lib)
-pkgver=1.13
+pkgver=1.14
_libver=1.9.3
-# stupid submodules
-_axver=1.8.2
-_ffiver=3.3
pkgrel=1
pkgdesc="Python3 for microcontrollers, with stdlib. (unix version)"
arch=('i686' 'x86_64')
@@ -14,18 +11,11 @@ license=('MIT')
depends=('readline' 'libffi' 'mbedtls')
makedepends=('python' 'python-setuptools' 'git')
options=('!emptydirs')
-source=("mpy-$pkgver.tgz::https://github.com/micropython/micropython/archive/v$pkgver.tar.gz"
- "mlib-$_libver.tgz::https://github.com/micropython/micropython-lib/archive/v$_libver.tar.gz"
- "axtls-$_axver.tgz::https://github.com/pfalcon/axtls/archive/v$_axver.tar.gz" # completely broken
- "ffi-$_ffiver.tgz::https://github.com/libffi/libffi/archive/v$_ffiver.tar.gz"
- "bdb.tgz::https://github.com/pfalcon/berkeley-db-1.xx/archive/embedded.tar.gz") # submodule with no releases!
-# What about the lwip submodule? The repo is GONE. You didn't need an IP stack anyway.
-# Maybe http://download.savannah.gnu.org/releases/lwip/lwip-2.0.0.zip is it?
-md5sums=('219d12f6017cd8a89a3c316e1c096091'
- '1752ce13e851a671a07ce3f7a807b21c'
- 'e11da4ef04499030d1eff69b474f34f0'
- 'f25aefb928eed09e858878382e10641f'
- 'SKIP')
+# They finally have a real release, without all the submodule garbage.
+source=("https://micropython.org/resources/source/micropython-$pkgver.tar.xz"
+ "mlib-$_libver.tgz::https://github.com/micropython/micropython-lib/archive/v$_libver.tar.gz")
+md5sums=('5db292b2bc1758b7d7062afbe9b0db0f'
+ '1752ce13e851a671a07ce3f7a807b21c')
@@ -33,15 +23,6 @@ md5sums=('219d12f6017cd8a89a3c316e1c096091'
# fix 'imported as namespace package' warnings from stdlib
prepare() {
- cd "$srcdir/micropython-$pkgver/lib"
- # fix submodules
- rmdir axtls
- rmdir libffi
- rmdir berkeley-db-1.xx
- ln -s "$srcdir/axtls-$_axver" axtls
- ln -s "$srcdir/libffi-$_ffiver" libffi
- ln -s "$srcdir/berkeley-db-1.xx-embedded" berkeley-db-1.xx
-
# fix makefile
cd "$srcdir/micropython-$pkgver/ports/unix"
sed -i 's|/local||' Makefile
@@ -66,6 +47,7 @@ build() {
check() {
cd "$srcdir/micropython-$pkgver/ports/unix"
+ # some tests appear non-deterministic
#make test
}
@@ -90,6 +72,11 @@ package_micropython-lib() {
error "Skipping $_d (no setup)"
continue
fi
+ # todo: fixing this probably involves overriding PYTHONPATH
+ if [[ "$_d" == "./types" ]]; then
+ error "Skipping $_d (unresolved name collision)"
+ continue
+ fi
msg "Installing $_d"
cd $_d
python3 setup.py install --prefix=/usr --root="$pkgdir" --install-lib='/usr/lib/micropython'