summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-08-25 16:41:35 +0800
committerwenLiangcan2015-08-25 16:41:35 +0800
commit0dc351dc93e73094e970adbc3ca7ff3e7f7204c6 (patch)
treea4571500a430fdfde2d250016d237f775f6ea6c7
parent1c671adfbaf40e1ebd5094142f9b79eb02545e0e (diff)
downloadaur-0dc351dc93e73094e970adbc3ca7ff3e7f7204c6.tar.gz
micropython-git-20150822-1.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5a2314fc750..ef758d7278c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = micropython-git
pkgdesc = Python 3 for microcontrollers, unix version.
- pkgver = 20150608
+ pkgver = 20150822
pkgrel = 1
url = http://micropython.org/
arch = i686
arch = x86_64
license = MIT
makedepends = git
+ makedepends = python
depends = readline
depends = libffi
+ optdepends = micropython-lib
provides = micropython
conflicts = micropython
- source = micropython::git://github.com/micropython/micropython.git
+ source = git://github.com/micropython/micropython.git
md5sums = SKIP
pkgname = micropython-git
diff --git a/PKGBUILD b/PKGBUILD
index 14f3bb933114..e802df7a5586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,36 @@
# Contributor: Kyle Keen <keenerd@gmail.com>
pkgname=micropython-git
-_pkgname=micropython
-pkgver=20150608
+pkgver=20150822
pkgrel=1
pkgdesc="Python 3 for microcontrollers, unix version."
arch=('i686' 'x86_64')
url="http://micropython.org/"
license=('MIT')
depends=('readline' 'libffi')
-makedepends=('git')
+makedepends=('git' 'python')
provides=('micropython')
conflicts=('micropython')
-source=("${_pkgname}"::'git://github.com/micropython/micropython.git')
+optdepends=('micropython-lib')
+source=('git://github.com/micropython/micropython.git')
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/micropython"
git log -1 --format='%cd' --date=short | tr -d -- '-'
}
build() {
- cd "${_pkgname}/unix"
+ cd "${srcdir}/micropython/unix"
+ sed -i 's|/local||' Makefile
make
}
package() {
- cd "${_pkgname}/unix"
- install -Dm755 "micropython" "${pkgdir}/usr/bin/micropython"
- install -Dm644 "../LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "${srcdir}/micropython/unix"
+ # install -Dm755 "micropython" "${pkgdir}/usr/bin/micropython"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "../LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}