summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2017-12-24 16:24:31 +0100
committerOleksandr Natalenko2017-12-24 16:24:31 +0100
commite698b0199394170d31c23a9b8dc341ec566c1fb9 (patch)
treed96921768d5561232d4b8ff36e4d3b2f33de0301
parentd1da6d3180d8c3af4b70c3765d0a4fa98bfbfbf4 (diff)
downloadaur-e698b0199394170d31c23a9b8dc341ec566c1fb9.tar.gz
reorganize files
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rwxr-xr-xmicrosip33
3 files changed, 31 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b9a95177380..ba094f3f0cee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Dec 24 14:58:57 UTC 2017
+# Sun Dec 24 15:24:20 UTC 2017
pkgbase = microsip
pkgdesc = Open source portable SIP softphone for Windows based on PJSIP stack
pkgver = 3.16.7
- pkgrel = 1
+ pkgrel = 2
url = https://www.microsip.org/
arch = x86_64
license = GPLv2
@@ -15,7 +15,7 @@ pkgbase = microsip
source = microsip
source = microsip.desktop
sha256sums = a68cf6b1e49e24c1ad808e98b90e129a0280f57af4602b752b76b88621ea313c
- sha256sums = d5c0b52d883524a2ba295864956471055298244618e2cde37727b8c5fd911f53
+ sha256sums = 42969a2fbc22b436f6ade3d496aafc7ec9c2d36b4e5867f793a5e35560757e66
sha256sums = d588c2b2e38e12d2be3dfdd9f2a63690293b884c7df240c441e271725b9a2ca2
pkgname = microsip
diff --git a/PKGBUILD b/PKGBUILD
index 341553a76190..be82a8832471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
pkgname=microsip
pkgver=3.16.7
-pkgrel=1
+pkgrel=2
pkgdesc="Open source portable SIP softphone for Windows based on PJSIP stack"
arch=('x86_64')
url="https://www.microsip.org/"
@@ -14,10 +14,10 @@ source=("MicroSIP-${pkgver}.zip"::"https://www.microsip.org/downloads/?file=Micr
"${pkgname}.desktop")
sha256sums=('a68cf6b1e49e24c1ad808e98b90e129a0280f57af4602b752b76b88621ea313c'
- 'd5c0b52d883524a2ba295864956471055298244618e2cde37727b8c5fd911f53'
+ '42969a2fbc22b436f6ade3d496aafc7ec9c2d36b4e5867f793a5e35560757e66'
'd588c2b2e38e12d2be3dfdd9f2a63690293b884c7df240c441e271725b9a2ca2')
-build() {
+prepare() {
cd "${srcdir}"
wrestool -x -t 14 microsip.exe >${pkgname}.ico
@@ -28,19 +28,19 @@ build() {
package() {
cd "${srcdir}"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "License.txt"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "MicroSIP Website.url"
+ install -Dt "${pkgdir}/usr/share/doc/${pkgname}" -m0644 "License.txt"
+ install -Dt "${pkgdir}/usr/share/doc/${pkgname}" -m0644 "MicroSIP Website.url"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "hangup.wav"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "messagein.wav"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "messageout.wav"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "ringin.wav"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "ringin2.wav"
+ install -Dt "${pkgdir}/usr/share/${pkgname}" -m0644 "ringout.wav"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "SDL.dll"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "avcodec-57.dll"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "avformat-57.dll"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "avutil-55.dll"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "hangup.wav"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "messagein.wav"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "messageout.wav"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "microsip.exe"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "ringin.wav"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "ringin2.wav"
- install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "ringout.wav"
install -Dt "${pkgdir}/usr/lib/${pkgname}" -m0644 "swscale-4.dll"
install -Dt "${pkgdir}/usr/bin" -m0755 "${pkgname}"
diff --git a/microsip b/microsip
index 8ec1adc52976..c521ca8882b2 100755
--- a/microsip
+++ b/microsip
@@ -1,24 +1,25 @@
#!/usr/bin/env bash
-__WINEPREFIX="${HOME}/.config/microsip"
-__APPDIR="${__WINEPREFIX}/dosdevices/c:/Program Files (x86)/microsip"
+__APPNAME=$(basename $0)
+__WINEPREFIX="${XDG_DATA_HOME:-$HOME/.local}/wine/${__APPNAME}"
+__APPDIR="${__WINEPREFIX}/dosdevices/c:/Program Files (x86)/${__APPNAME}"
mkdir -p "${__APPDIR}"
-ln -sf "/usr/lib/microsip/License.txt" "${__APPDIR}/License.txt"
-ln -sf "/usr/lib/microsip/MicroSIP Website.url" "${__APPDIR}/MicroSIP Website.url"
-ln -sf "/usr/lib/microsip/SDL.dll" "${__APPDIR}/SDL.dll"
-ln -sf "/usr/lib/microsip/avcodec-57.dll" "${__APPDIR}/avcodec-57.dll"
-ln -sf "/usr/lib/microsip/avformat-57.dll" "${__APPDIR}/avformat-57.dll"
-ln -sf "/usr/lib/microsip/avutil-55.dll" "${__APPDIR}/avutil-55.dll"
-ln -sf "/usr/lib/microsip/hangup.wav" "${__APPDIR}/hangup.wav"
-ln -sf "/usr/lib/microsip/messagein.wav" "${__APPDIR}/messagein.wav"
-ln -sf "/usr/lib/microsip/messageout.wav" "${__APPDIR}/messageout.wav"
-ln -sf "/usr/lib/microsip/microsip.exe" "${__APPDIR}/microsip.exe"
-ln -sf "/usr/lib/microsip/ringin.wav" "${__APPDIR}/ringin.wav"
-ln -sf "/usr/lib/microsip/ringin2.wav" "${__APPDIR}/ringin2.wav"
-ln -sf "/usr/lib/microsip/ringout.wav" "${__APPDIR}/ringout.wav"
-ln -sf "/usr/lib/microsip/swscale-4.dll" "${__APPDIR}/swscale-4.dll"
+ln -sf "/usr/share/doc/${__APPNAME}/License.txt" "${__APPDIR}/License.txt"
+ln -sf "/usr/share/doc/${__APPNAME}/MicroSIP Website.url" "${__APPDIR}/MicroSIP Website.url"
+ln -sf "/usr/share/${__APPNAME}/hangup.wav" "${__APPDIR}/hangup.wav"
+ln -sf "/usr/share/${__APPNAME}/messagein.wav" "${__APPDIR}/messagein.wav"
+ln -sf "/usr/share/${__APPNAME}/messageout.wav" "${__APPDIR}/messageout.wav"
+ln -sf "/usr/share/${__APPNAME}/ringin.wav" "${__APPDIR}/ringin.wav"
+ln -sf "/usr/share/${__APPNAME}/ringin2.wav" "${__APPDIR}/ringin2.wav"
+ln -sf "/usr/share/${__APPNAME}/ringout.wav" "${__APPDIR}/ringout.wav"
+ln -sf "/usr/lib/${__APPNAME}/SDL.dll" "${__APPDIR}/SDL.dll"
+ln -sf "/usr/lib/${__APPNAME}/avcodec-57.dll" "${__APPDIR}/avcodec-57.dll"
+ln -sf "/usr/lib/${__APPNAME}/avformat-57.dll" "${__APPDIR}/avformat-57.dll"
+ln -sf "/usr/lib/${__APPNAME}/avutil-55.dll" "${__APPDIR}/avutil-55.dll"
+ln -sf "/usr/lib/${__APPNAME}/microsip.exe" "${__APPDIR}/microsip.exe"
+ln -sf "/usr/lib/${__APPNAME}/swscale-4.dll" "${__APPDIR}/swscale-4.dll"
WINEPREFIX="${__WINEPREFIX}" wine "${__APPDIR}/microsip.exe"