summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbittin2021-05-01 09:39:52 +0200
committerbittin2021-05-01 09:39:52 +0200
commita918d02ca3ee824066dca79c915f3612b3f29b13 (patch)
tree29d3ddca328128def21e9d65b0aeda131535ab9f
downloadaur-a918d02ca3ee824066dca79c915f3612b3f29b13.tar.gz
Microsoft Edge Beta
-rw-r--r--.SRCINFO40
-rw-r--r--Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdfbin0 -> 87033 bytes
-rw-r--r--PKGBUILD66
-rw-r--r--microsoft-edge-beta.sh15
4 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9eadc6f839c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = microsoft-edge-beta-bin
+ pkgdesc = A browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier
+ pkgver = 91.0.864.11
+ pkgrel = 1
+ url = https://www.microsoftedgeinsider.com/en-us/download
+ arch = x86_64
+ license = custom
+ makedepends = imagemagick
+ depends = gtk3
+ depends = libcups
+ depends = nss
+ depends = alsa-lib
+ depends = libxtst
+ depends = libdrm
+ depends = mesa
+ optdepends = libpipewire02: WebRTC desktop sharing under Wayland
+ optdepends = kdialog: for file dialogs in KDE
+ optdepends = gnome-keyring: for storing passwords in GNOME keyring
+ optdepends = kwallet: for storing passwords in KWallet
+ optdepends = gtk3: for printing
+ optdepends = libunity: for download progress on KDE
+ optdepends = ttf-liberation: fix fonts for some PDFs - CRBug #369991
+ optdepends = xdg-utils
+ provides = microsoft-edge-beta
+ provides = edge-beta
+ conflicts = microsoft-edge-beta
+ conflicts = edge-beta
+ conflicts = edge-beta-bin
+ conflicts = edge
+ options = !strip
+ options = !zipman
+ source = https://packages.microsoft.com/repos/edge/pool/main/m/microsoft-edge-beta/microsoft-edge-beta_91.0.864.11-1_amd64.deb
+ source = microsoft-edge-beta.sh
+ source = Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf
+ sha256sums = 1504d3d15cbeada93478d1c813137a9bd88c998a76af930111ac6bccd6f1dd06
+ sha256sums = 285afe53b2cd617ae7f4930a1d0befe12a97ae31c30cfad74e97bf695c6f6a8a
+ sha256sums = edf2ed596eb068f168287fc76aa713ad5e0afb59f0a0a47a4f29c0c124ade15e
+
+pkgname = microsoft-edge-beta-bin
+
diff --git a/Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf b/Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf
new file mode 100644
index 000000000000..ac3251c09abe
--- /dev/null
+++ b/Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ddb68a9102a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Luna Jernberg <droidbittin@gmail.com>
+
+
+pkgname=microsoft-edge-beta-bin
+_pkgname=microsoft-edge-beta
+_pkgshortname=msedge-beta
+pkgver=91.0.864.11
+pkgrel=1
+pkgdesc="A browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier"
+arch=('x86_64')
+url="https://www.microsoftedgeinsider.com/en-us/download"
+license=('custom')
+provides=('microsoft-edge-beta' 'edge-beta')
+conflicts=('microsoft-edge-beta' 'edge-beta' 'edge-beta-bin' 'edge')
+depends=('gtk3' 'libcups' 'nss' 'alsa-lib' 'libxtst' 'libdrm' 'mesa')
+makedepends=('imagemagick')
+optdepends=('libpipewire02: WebRTC desktop sharing under Wayland'
+ 'kdialog: for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
+ 'kwallet: for storing passwords in KWallet'
+ 'gtk3: for printing'
+ 'libunity: for download progress on KDE'
+ 'ttf-liberation: fix fonts for some PDFs - CRBug #369991'
+ 'xdg-utils')
+options=(!strip !zipman)
+_channel=beta
+source=("https://packages.microsoft.com/repos/edge/pool/main/m/microsoft-edge-beta/${_pkgname}_${pkgver}-1_amd64.deb"
+ "microsoft-edge-beta.sh"
+ "Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf")
+sha256sums=('1504d3d15cbeada93478d1c813137a9bd88c998a76af930111ac6bccd6f1dd06'
+ '285afe53b2cd617ae7f4930a1d0befe12a97ae31c30cfad74e97bf695c6f6a8a'
+ 'edf2ed596eb068f168287fc76aa713ad5e0afb59f0a0a47a4f29c0c124ade15e')
+
+package() {
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+
+ # suid sandbox
+ chmod 4755 "${pkgdir}/opt/microsoft/${_pkgshortname}/msedge-sandbox"
+
+ # 256 and 24 are proper colored icons
+ for res in 128 64 48 32; do
+ convert "${pkgdir}/opt/microsoft/${_pkgshortname}/product_logo_256_beta.png" \
+ -resize ${res}x${res} \
+ "${pkgdir}/opt/microsoft/${_pkgshortname}/product_logo_${res}_beta.png"
+ done
+ for res in 22 16; do
+ convert "${pkgdir}/opt/microsoft/${_pkgshortname}/product_logo_24_beta.png" \
+ -resize ${res}x${res} \
+ "${pkgdir}/opt/microsoft/${_pkgshortname}/product_logo_${res}_beta.png"
+ done
+
+ # install icons
+ for res in 16 22 24 32 48 64 128 256; do
+ install -Dm644 "${pkgdir}/opt/microsoft/${_pkgshortname}/product_logo_${res}_beta.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_pkgname}.png"
+ done
+
+ # User flag aware launcher
+ install -m755 microsoft-edge-beta.sh "${pkgdir}/usr/bin/microsoft-edge-beta"
+
+ # License
+ install -Dm644 'Microsoft Standard Application License Terms - Standalone (free) Use Terms.pdf' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.pdf"
+ rm -r "${pkgdir}/etc/cron.daily/" "${pkgdir}/opt/microsoft/${_pkgshortname}/cron/"
+ # Globbing seems not to work inside double parenthesis
+ rm "${pkgdir}/opt/microsoft/${_pkgshortname}"/product_logo_*.png
+}
diff --git a/microsoft-edge-beta.sh b/microsoft-edge-beta.sh
new file mode 100644
index 000000000000..47c4b17c9a27
--- /dev/null
+++ b/microsoft-edge-beta.sh
@@ -0,0 +1,15 @@
+#!/usr/bin/env sh
+# Launches MS Edge with flags specified in $XDG_CONFIG_HOME/microsoft-edge-beta-flags.conf
+
+# Make script fail if `cat` fails for some reason
+set -e
+
+# Set default value if variable is unset/null
+XDG_CONFIG_HOME="${XDG_CONFIG_HOME:-${HOME}/.config}"
+
+# Attempt to read a config file if it exists
+if [ -r "${XDG_CONFIG_HOME}/microsoft-edge-beta-flags.conf" ]; then
+ EDGE_USER_FLAGS="$(cat "$XDG_CONFIG_HOME/microsoft-edge-beta-flags.conf")"
+fi
+
+exec /opt/microsoft/msedge-dev/microsoft-edge-beta $EDGE_USER_FLAGS "$@"