summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2023-10-11 11:48:50 +0200
committerDan Johansen2023-10-11 11:48:50 +0200
commit70d7f89254944ad763d2391cc3821f98b2787efc (patch)
tree637ca4c94c52dc815ae78b62fe6ed93f08d047c2
downloadaur-70d7f89254944ad763d2391cc3821f98b2787efc.tar.gz
initial commit, version 1.6.1
Signed-off-by: Dan Johansen <strit@strits.dk>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD29
-rw-r--r--microsoft-identity-broker-bin.install25
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8426bbf59888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = microsoft-identity-broker-bin
+ pkgdesc = Broker for authentication between device and Microsoft Intune
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://packages.microsoft.com/ubuntu/20.04/prod/pool/main/m/microsoft-identity-broker
+ install = microsoft-identity-broker-bin.install
+ arch = x86_64
+ license = Unknown
+ depends = dbus
+ depends = gnome-keyring
+ depends = systemd
+ depends = jre11-openjdk
+ provides = msft-identity-broker=1.6.1
+ provides = microsoft-identity-broker
+ conflicts = msft-identity-broker
+ conflicts = microsoft-identity-broker
+ replaces = msft-identity-broker
+ replaces = microsoft-identity-broker
+ source_x86_64 = https://packages.microsoft.com/ubuntu/20.04/prod/pool/main/m/microsoft-identity-broker/microsoft-identity-broker_1.6.1_amd64.deb
+ sha256sums_x86_64 = 0accbbc7086ad733257ccf991a181302d7e7243b99aa663f856424ff56885461
+
+pkgname = microsoft-identity-broker-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78e7a8f6a072
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dan Johansen <strit@strits.dk>
+# Contributor: Recolic K <root@recolic.net>
+
+pkgname=microsoft-identity-broker-bin
+_pkgname=microsoft-identity-broker
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Broker for authentication between device and Microsoft Intune"
+url="https://packages.microsoft.com/ubuntu/20.04/prod/pool/main/m/${_pkgname}"
+license=("Unknown")
+arch=("x86_64")
+depends=("dbus" "gnome-keyring" "systemd" "jre11-openjdk")
+provides=("msft-identity-broker=${pkgver}" "${_pkgname}")
+conflicts=("msft-identity-broker" "${_pkgname}")
+replaces=("msft-identity-broker" "${_pkgname}")
+source_x86_64=("$url/${_pkgname}_${pkgver}_amd64.deb")
+sha256sums_x86_64=('0accbbc7086ad733257ccf991a181302d7e7243b99aa663f856424ff56885461')
+install=${pkgname}.install
+
+package() {
+ cd "$srcdir"
+ tar xvzf data.tar.gz
+ echo ">>> Patching... (Hardcode archlinux java11 JAVA_HOME into xxx.service)"
+ echo 'Environment="JAVA_HOME=/usr/lib/jvm/java-11-openjdk"' >> "$srcdir/usr/lib/systemd/system/microsoft-identity-device-broker.service"
+ echo 'Environment="JAVA_HOME=/usr/lib/jvm/java-11-openjdk"' >> "$srcdir/usr/lib/systemd/user/${_pkgname}.service"
+ cp -r "$srcdir/usr" "$srcdir/opt" "$pkgdir/"
+}
+
+
diff --git a/microsoft-identity-broker-bin.install b/microsoft-identity-broker-bin.install
new file mode 100644
index 000000000000..e83f727c82c0
--- /dev/null
+++ b/microsoft-identity-broker-bin.install
@@ -0,0 +1,25 @@
+post_install() {
+ # Recolic: I believe it's not necessary to start the service at all. This service is triggered by edge from libsdbus.
+ # I don't know why they are doing this. just leave them there.
+ if [ -d /run/systemd/system ]; then
+ systemctl --system daemon-reload || true
+ # systemctl restart microsoft-identity-device-broker.service || true
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ if [ -d /run/systemd/system ]; then
+ systemctl stop microsoft-identity-device-broker.service || true
+ fi
+}
+
+post_remove() {
+ if [ -d /run/systemd/system ]; then
+ systemctl --system daemon-reload || true
+ fi
+}
+