summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliuzhe2018-09-10 19:19:21 +0800
committerliuzhe2018-09-10 19:19:21 +0800
commitf783e1f98d77a7c3473953821c696557473289b4 (patch)
tree166b1f0ff045f04e4af3f4cec17c8a9b8d5e82a4
parent2db95baabe103ed68158c3c732c2c6f98f665b5d (diff)
downloadaur-f783e1f98d77a7c3473953821c696557473289b4.tar.gz
update pkgver and add missing dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed5348abca6..a71a474edbcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = microsoft-nni-git
pkgdesc = An open source toolkit for neural architecture search, hyper-parameter optimization and optimizer design
- pkgver = 0.1.0.r28.f1c2b70
+ pkgver = 0.1.r1.g7a7ab75
pkgrel = 1
url = https://github.com/microsoft/nni
arch = x86_64
@@ -16,6 +16,7 @@ pkgbase = microsoft-nni-git
depends = python-yaml
depends = python-requests
depends = python-scipy
+ depends = python-hyperopt
provides = microsoft-nni
conflicts = microsoft-nni
source = git://github.com/microsoft/nni.git
diff --git a/PKGBUILD b/PKGBUILD
index 2bbbc6458f5c..98d96311ec83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Liu Zhe <cruise.pas@gmail.com>
pkgname=microsoft-nni-git
-pkgver=0.1.0.r28.f1c2b70
+pkgver=0.1.r1.g7a7ab75
pkgrel=1
pkgdesc='An open source toolkit for neural architecture search, hyper-parameter optimization and optimizer design'
arch=('x86_64')
url='https://github.com/microsoft/nni'
license=('MIT')
-depends=('nodejs-serve' 'python-astor' 'python-json-tricks' 'python-psutil' 'python-yaml' 'python-requests' 'python-scipy')
+depends=('nodejs-serve' 'python-astor' 'python-json-tricks' 'python-psutil' 'python-yaml' 'python-requests' 'python-scipy' 'python-hyperopt')
makedepends=('git' 'yarn' 'typescript' 'python-setuptools')
provides=('microsoft-nni')
conflicts=('microsoft-nni')
@@ -17,7 +17,7 @@ sha1sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir"/nni
- echo 0.1.0.r$(git rev-list --count master).$(git rev-parse --short master)
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {