summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2019-06-20 21:49:37 +0200
committerJan Alexander Steffens (heftig)2019-06-20 21:49:37 +0200
commitb6f4a5facbc7bcde18eac8856154467e1c9cb1c8 (patch)
tree430660c2072e3f2a7480ab223b3d06e3fb679713
parent66ddd05541313e8be4e474b4015dbacd66182bf3 (diff)
downloadaur-b6f4a5facbc7bcde18eac8856154467e1c9cb1c8.tar.gz
0.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4abfbc3eae8..da23dddd4356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = microsoft-python-language-server
pkgdesc = Microsoft Language Server for Python
- pkgver = 2019.1
+ pkgver = 0.2
pkgrel = 1
+ epoch = 1
url = https://github.com/Microsoft/python-language-server
arch = any
license = Apache
makedepends = dotnet-sdk
+ makedepends = git
depends = dotnet-runtime
- source = microsoft-python-language-server::git+https://github.com/Microsoft/python-language-server#tag=2019.1
+ source = microsoft-python-language-server::git+https://github.com/Microsoft/python-language-server#tag=0.2
validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0714c4d57f9b..3b1973d24c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgname=microsoft-python-language-server
-pkgver=2019.1
+pkgver=0.2
pkgrel=1
+epoch=1
pkgdesc="Microsoft Language Server for Python"
url="https://github.com/Microsoft/python-language-server"
arch=(any)
license=(Apache)
depends=(dotnet-runtime)
-makedepends=(dotnet-sdk)
+makedepends=(dotnet-sdk git)
source=("$pkgname::git+$url#tag=$pkgver")
sha256sums=('SKIP')
validpgpkeys=('5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23')
@@ -25,7 +26,10 @@ build() {
package() {
cd $pkgname/src/LanguageServer/Impl
- dotnet publish -c Release --no-build -o "$pkgdir/usr/lib/$pkgname"
+
+ # Returns 1 but reports no error (???)
+ dotnet publish -c Release --no-build -o "$pkgdir/usr/lib/$pkgname" || :
+
install -D /dev/stdin "$pkgdir/usr/bin/mspyls" <<END
#!/bin/sh
exec dotnet /usr/lib/$pkgname/Microsoft.Python.LanguageServer.dll "\$@"