summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblinry2022-02-12 12:20:46 +0100
committerblinry2022-02-12 12:20:46 +0100
commit3f20b771b476ee96216ffe5cdfade152c7986f92 (patch)
tree13c672ec04a6fce741cd15076fb37d25c611b463
downloadaur-3f20b771b476ee96216ffe5cdfade152c7986f92.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39ba701e8daa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = microw8
+ pkgdesc = WebAssembly based fantasy console
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://exoticorn.github.io/microw8/
+ arch = x86_64
+ license = Unlicense
+ source = https://github.com/exoticorn/microw8/releases/download/v0.1.1/microw8-0.1.1-linux.tgz
+ sha256sums = fa585cc96fbc54819662c2e438f463c20aee9539fc779c3b85c278c18fb19316
+
+pkgname = microw8
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6830aa4027b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: blinry <mail@blinry.org>
+
+pkgname=microw8
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="WebAssembly based fantasy console"
+arch=('x86_64')
+url="https://exoticorn.github.io/microw8/"
+license=('Unlicense')
+source=(https://github.com/exoticorn/microw8/releases/download/v$pkgver/microw8-$pkgver-linux.tgz)
+sha256sums=('fa585cc96fbc54819662c2e438f463c20aee9539fc779c3b85c278c18fb19316')
+
+package() {
+ cd "$srcdir/microw8-linux/"
+ install -Dm755 uw8 "$pkgdir/usr/bin/uw8"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/microw8/README.md"
+ install -Dm644 microw8.html "$pkgdir/usr/share/doc/microw8/microw8.html"
+ install -Dm644 examples/* -t "$pkgdir/usr/share/doc/microw8/examples/"
+ install -Dm644 carts/* -t "$pkgdir/usr/share/doc/microw8/carts/"
+}