summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPopolon2023-12-17 00:28:13 +0100
committerPopolon2023-12-17 00:28:13 +0100
commit8a10207ce2eb778d8fc318f0ae374282e8c2e9f1 (patch)
tree3ace89435714d08595cc38c8bffd44644034f002
downloadaur-8a10207ce2eb778d8fc318f0ae374282e8c2e9f1.tar.gz
initial commit, as the author of the other package don't want to make it from sources nor update it
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f645f9dcfc8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = microw8-src
+ pkgdesc = WebAssembly based fantasy console inspired by the likes of TIC-80, WASM-4 and PICO-8.
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = https://exoticorn.github.io/microw8
+ arch = x86_64
+ arch = armv7h
+ arch = armv8
+ arch = riscv32
+ arch = riscv64
+ license = The Unlicense
+ makedepends = rust
+ source = https://github.com/exoticorn/microw8/archive/refs/tags/v0.2.2.tar.gz
+ sha256sums = 20018bd1bd5e0081d25ac1f77c4bcab1874a0c26df1001cfd51ca256d0e46f79
+
+pkgname = microw8-src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3c0789e7e28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Popolon <popolon(aLpopolon.org>
+
+pkgname=microw8-src
+_pkgname=microw8
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="WebAssembly based fantasy console inspired by the likes of TIC-80, WASM-4 and PICO-8."
+arch=('x86_64' 'armv7h' 'armv8' 'riscv32' 'riscv64')
+url='https://exoticorn.github.io/microw8'
+license=('The Unlicense')
+makedepends=('rust')
+source=("https://github.com/exoticorn/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('20018bd1bd5e0081d25ac1f77c4bcab1874a0c26df1001cfd51ca256d0e46f79')
+
+#prepare() {
+# cd "${pkgname}-${pkgver}"
+# patch -p1 -i "${srcdir}"/fix-gcc13-build.patch
+#}
+
+build() {
+ cd ${_pkgname}-${pkgver}/
+ cargo build --release
+}
+
+#check() {
+# cmake --build build --target test
+#}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ install -Dm755 "target/release/uw8" "$pkgdir/usr/bin/uw8"
+ mkdir -p ${pkgdir}/usr/share/doc/microw8
+ cp -a examples ${pkgdir}/usr/share/doc/microw8/
+ install -Dm644 UNLICENSE -t "$pkgdir/usr/share/licenses/microw8/UNLICENSE"
+ #install -Dm644 README.md "$pkgdir/usr/share/doc/microw8/README.md"
+ #install -Dm644 microw8.html "$pkgdir/usr/share/doc/microw8/microw8.html"
+}