summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2022-02-21 14:53:35 +0100
committerBrainDamage2022-02-21 14:53:35 +0100
commit6ec67204e55bc261c271a36cc41cb75d6d016994 (patch)
tree03a253dbe6abfc56027c1eec35f18f7e4d4e997a
parentc805300d4963e3878c3db2b6a74bd69c39501899 (diff)
downloadaur-mididings-git.tar.gz
changed upstream url to a fork that builds without patches
use find/install instead of shell globbing
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 570efbad3633..104d2c70c1cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mididings-git
pkgdesc = A MIDI router and processor based on Python, supporting ALSA and JACK MIDI (python3 patched)
- pkgver = r706.bbec99a
- pkgrel = 4
+ pkgver = r717.0582955
+ pkgrel = 1
url = http://das.nasophon.de/mididings/
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = mididings-git
optdepends = tk: for the livedings GUI
provides = mididings
conflicts = mididings
- source = mididings-git::git+https://github.com/dsacre/mididings
+ source = mididings-git::git+https://github.com/ponderworthy/mididings
md5sums = SKIP
pkgname = mididings-git
diff --git a/PKGBUILD b/PKGBUILD
index 97b3849bf583..ed1faf801eab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname_=mididings
pkgname=${pkgname_}-git
-pkgver=r706.bbec99a
-pkgrel=4
+pkgver=r717.0582955
+pkgrel=1
pkgdesc="A MIDI router and processor based on Python, supporting ALSA and JACK MIDI (python3 patched)"
arch=('i686' 'x86_64')
url="http://das.nasophon.de/mididings/"
@@ -19,7 +19,7 @@ optdepends=('python-dbus: to send DBUS messages'
'python-pyinotify: to automatically restart when a script changes'
'python-xdg: so mididings knows where to look for config files'
'tk: for the livedings GUI')
-source=("${pkgname}::git+https://github.com/dsacre/mididings")
+source=("${pkgname}::git+https://github.com/ponderworthy/mididings")
md5sums=('SKIP')
pkgver() {
@@ -27,27 +27,19 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- # fix integer division
- gawk -i inplace 'NR==42 { sub("/", "//") }; { print }' mididings/extra/harmonizer.py
- # async is a reserved keyword in python3
- gawk -i inplace '{ gsub("async", "asyncFlag") }; { print }' mididings/units/call.py
-}
-
build() {
cd "${srcdir}/${pkgname}"
python setup.py build
+ # documentation generation not functional
+ # cd "${srcdir}/${pkgname}/doc"
+ # make
}
package() {
cd "${srcdir}/${pkgname}"
python setup.py install --skip-build --prefix=/usr --root="${pkgdir}"
- # docs
- install -d "${pkgdir}/usr/share/doc/${pkgname_}/examples"
- install -Dm644 doc/*.* "${pkgdir}/usr/share/doc/${pkgname_}"
-
- # examples
- install -Dm644 doc/examples/* "${pkgdir}/usr/share/doc/${pkgname_}/examples"
+ # manual installation of raw docs
+ cd "${srcdir}/${pkgname}/doc"
+ find . -exec install -Dvm 644 {} "${pkgdir}/usr/share/doc/${pkgname_}/{}" \;
}