summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2019-10-29 16:35:02 +0100
committerBrainDamage2019-10-29 16:35:02 +0100
commit8431d026565cf665db36821a029e32f8b3b091ee (patch)
treeaffcd966b52f5f680f2e36eabba72fe2809b3eff
downloadaur-8431d026565cf665db36821a029e32f8b3b091ee.tar.gz
initial version
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0283bb35b187
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mididings-git
+ pkgdesc = A MIDI router and processor based on Python, supporting ALSA and JACK MIDI (python3 patched)
+ pkgver = 20191029.bbec99a
+ pkgrel = 1
+ url = http://das.nasophon.de/mididings/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = boost-libs
+ depends = python-decorator
+ depends = jack
+ optdepends = python-dbus: to send DBUS messages
+ optdepends = python-pyliblo: to send or receive OSC messages
+ optdepends = python-pyinotify: to automatically restart when a script changes
+ optdepends = python-xdg: so mididings knows where to look for config files
+ optdepends = tk: for the livedings GUI
+ provides = mididings
+ conflicts = mididings
+ source = mididings-git::git+https://github.com/dsacre/mididings
+ md5sums = SKIP
+
+pkgname = mididings-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..331ac7bf6fd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: BrainDamage
+# Contributor: Leonard de Ruijter <dev@systeemdenker.nl>
+# Contributor: speps <speps at aur dot archlinux dot org>
+
+pkgname_=mididings
+pkgname=$pkgname_-git
+pkgver=20191029.bbec99a
+pkgrel=1
+pkgdesc="A MIDI router and processor based on Python, supporting ALSA and JACK MIDI (python3 patched)"
+arch=('i686' 'x86_64')
+url="http://das.nasophon.de/mididings/"
+license=('GPL')
+depends=('boost-libs' 'python-decorator' 'jack')
+makedepends=('boost')
+provides=("$pkgname_")
+conflicts=("$pkgname_")
+optdepends=('python-dbus: to send DBUS messages'
+ 'python-pyliblo: to send or receive OSC messages'
+ 'python-pyinotify: to automatically restart when a script changes'
+ 'python-xdg: so mididings knows where to look for config files'
+ 'tk: for the livedings GUI')
+source=("$pkgname::git+https://github.com/dsacre/mididings")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # uuuugly code to use date + current git hash in lieu of absent release tag
+ echo "$(date +%Y%m%d).$(git describe --always)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ # fix integer division
+ gawk -i inplace 'NR==42 { sub("/", "//") }; { print }' mididings/extra/harmonizer.py
+ # async is a reserved keyword in python3
+ gawk -i inplace '{ gsub("async", "asyncFlag") }; { print }' mididings/units/call.py
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+
+ # docs
+ install -d "$pkgdir/usr/share/doc/$pkgname_/examples"
+ install -Dm644 doc/*.* "$pkgdir/usr/share/doc/$pkgname_"
+
+ # examples
+ install -Dm644 doc/examples/* "$pkgdir/usr/share/doc/$pkgname_/examples"
+}