summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasyncial2017-08-28 12:31:10 +0200
committerasyncial2017-08-28 12:31:10 +0200
commit47ceb7b73ffa09e1de85971241586d8cd515b344 (patch)
treeb06bcb68c2e226d67ff272954ec435ad850be196
downloadaur-47ceb7b73ffa09e1de85971241586d8cd515b344.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..277cc6010e63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = midna-themes
+ pkgdesc = KaOS Plasma 5 Look & Feel theme files
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = http://kaosx.us
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ depends = plasma-framework
+ depends = qtcurve-qt5
+ depends = ttf-raleway
+ conflicts = kde-kdm-themes-midna
+ conflicts = kde-ksplash-themes-midna
+ conflicts = kde-plasma-themes-midna
+ replaces = kde-kdm-themes-midna
+ replaces = kde-ksplash-themes-midna
+ replaces = kde-plasma-themes-midna
+ source = git://github.com/KaOSx/midna.git
+ md5sums = SKIP
+
+pkgname = midna-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..364df6900352
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: asyncial <asyncial [dot] posteo [dot] de>
+
+pkgname=midna-themes
+pkgver=2.1.0
+pkgrel=1
+pkgdesc='KaOS Plasma 5 Look & Feel theme files'
+url='http://kaosx.us'
+arch=('x86_64')
+license=('LGPL')
+depends=('plasma-framework' 'qtcurve-qt5' 'ttf-raleway')
+makedepends=('extra-cmake-modules')
+conflicts=('kde-kdm-themes-midna'
+ 'kde-ksplash-themes-midna'
+ 'kde-plasma-themes-midna' )
+replaces=('kde-kdm-themes-midna'
+ 'kde-ksplash-themes-midna'
+ 'kde-plasma-themes-midna' )
+source=("git://github.com/KaOSx/midna.git")
+md5sums=('SKIP')
+
+build() {
+ mkdir -p build
+ cd build
+
+ cmake ../midna \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+
+ make DESTDIR=${pkgdir} install
+}