summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-04-27 19:56:20 +1200
committerGeorge Rawlinson2022-04-27 19:56:20 +1200
commit46405215278b6e963f4e6327f8eac852bd8a46d0 (patch)
treea5e33b12858ddb00b7fdf074d6fa9bc581cc0ece
parent65c9675b1eea548e759af0361e373c184401669b (diff)
downloadaur-46405215278b6e963f4e6327f8eac852bd8a46d0.tar.gz
upgpkg: mightymike 3.0.1-1
New upstream release.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD40
2 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dec9f527002c..397c1bab2c30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mightymike
pkgdesc = High Powered Action Rescue in a Toy Store Gone Mad
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/jorio/mightymike
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
- makedepends = cmake
makedepends = git
+ makedepends = cmake
depends = sdl2
depends = glu
depends = hicolor-icon-theme
- source = mightymike::git+https://github.com/jorio/mightymike.git#tag=v3.0.0
- source = git+https://github.com/jorio/Pomme.git
+ source = mightymike::git+https://github.com/jorio/mightymike#commit=704ed5232081912d11b18edf423ca7823a98dd82
+ source = github.com-jorio-Pomme::git+https://github.com/jorio/Pomme
source = mightymike.desktop
source = mightymike.sh
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index adb623e8a025..27b6947fd312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=mightymike
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
-pkgdesc="High Powered Action Rescue in a Toy Store Gone Mad"
+pkgdesc='High Powered Action Rescue in a Toy Store Gone Mad'
arch=('x86_64')
-url="https://github.com/jorio/mightymike"
+url='https://github.com/jorio/mightymike'
license=('custom:CC-BY-NC-SA-4.0')
depends=('sdl2' 'glu' 'hicolor-icon-theme')
-makedepends=('cmake' 'git')
+makedepends=('git' 'cmake')
+_commit='704ed5232081912d11b18edf423ca7823a98dd82'
source=(
- "$pkgname::git+$url.git#tag=v$pkgver"
- 'git+https://github.com/jorio/Pomme.git'
+ "$pkgname::git+$url#commit=$_commit"
+ 'github.com-jorio-Pomme::git+https://github.com/jorio/Pomme'
"$pkgname.desktop"
"$pkgname.sh"
)
@@ -20,19 +21,30 @@ b2sums=('SKIP'
'6cd424b2dc3628731e42ae22917cd51e2eb47178bb79ee5c77ae07f3cde10f9404b53c5bf4c2f444aac0ecb3363e5141fc9fd206307a1a2bf819315c5900dec8'
'f5a0b6aaf304db6e04e8487c84677f8dc1dc877ce384ef24faece43484c4872f2422f3c4dd016b3ec804d47d1635e6b289bc4f9d6d32a98e65063ef275792e34')
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
+
prepare() {
cd "$pkgname"
+
git submodule init
- git config submodule.Pomme.url ../Pomme
- git submodule update
- cmake -S . -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev
+ git config submodule.extern/Pomme.url "$srcdir/github.com-jorio-Pomme"
+ git submodule update --init --recursive
}
build() {
cd "$pkgname"
+
+ cmake \
+ -S . \
+ -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+
cmake --build build
}
@@ -48,14 +60,14 @@ package() {
# desktop file & icon
install -vDm644 -t "$pkgdir/usr/share/applications" "$srcdir/$pkgname.desktop"
- install -vDm644 cmake/MightyMike512.png \
+ install -vDm644 packaging/MightyMike512.png \
"$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
# documentation
install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" *.md
rm -vf "$pkgdir/usr/share/doc/$pkgname/LICENSE.md"
cp -vr docs "$pkgdir/usr/share/doc/$pkgname"
- sed -e "s/@PROJECT_VERSION@/$pkgver/" cmake/ReadMe.txt.in \
+ sed -e "s/@PROJECT_VERSION@/$pkgver/" packaging/ReadMe.txt.in \
> "$pkgdir/usr/share/doc/$pkgname/README"
# license