summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkash Patel2023-03-07 00:51:10 -0600
committerGitHub2023-03-07 07:51:10 +0100
commit0b114b1ebcc3b4cee8651b0c384da242e829e413 (patch)
treed0148d89ff11e152652469c4856d0e91746c6889
parentc51755f465f6a91e71a640694b327f2285bd034f (diff)
downloadaur-0b114b1ebcc3b4cee8651b0c384da242e829e413.tar.gz
upgpkg: migraphx 5.4.3-1 (#956)
Add patch for finding msgpack cmake module
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dc452466db4..356341a02efe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = migraphx
- pkgdesc = AMD's graph optimization engine
- pkgver = 5.3.0
- pkgrel = 2
+ pkgdesc = AMD's graph optimization engine.
+ pkgver = 5.4.3
+ pkgrel = 1
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
license = MIT
@@ -14,9 +14,11 @@ pkgbase = migraphx
depends = protobuf
depends = msgpack-cxx
depends = blaze
- source = migraphx-5.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-5.3.0.tar.gz
+ source = migraphx-5.4.3.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-5.4.3.tar.gz
source = include-array.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1435.patch
- sha256sums = d0b7283f42e03fb38b612868b8c94f46f27a6e0b019ae95fde5b9086582a1c69
+ source = msgpack.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1603.patch
+ sha256sums = f83e7bbe5d6d0951fb2cf0abf7e8b3530e9a5e45f7cec6d760da055d6905d568
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = migraphx
diff --git a/PKGBUILD b/PKGBUILD
index bc6b7b4d8fdd..547eccf4f599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=5.3.0
-pkgrel=2
-pkgdesc="AMD's graph optimization engine"
+pkgver=5.4.3
+pkgrel=1
+pkgdesc="AMD's graph optimization engine."
arch=('x86_64')
url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
@@ -11,14 +11,17 @@ depends=('hip' 'miopen' 'protobuf' 'msgpack-cxx' 'blaze')
makedepends=('rocm-cmake' 'nlohmann-json' 'half' 'pybind11')
_git='https://github.com/ROCmSoftwarePlatform/AMDMIGraphX'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
- "include-array.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1435.patch")
-sha256sums=('d0b7283f42e03fb38b612868b8c94f46f27a6e0b019ae95fde5b9086582a1c69'
+ "include-array.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1435.patch"
+ "msgpack.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1603.patch")
+sha256sums=('f83e7bbe5d6d0951fb2cf0abf7e8b3530e9a5e45f7cec6d760da055d6905d568'
+ 'SKIP'
'SKIP')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
prepare() {
cd "$_dirname"
patch -Np1 -i "$srcdir/include-array.patch"
+ patch -Np1 -i "$srcdir/msgpack.patch"
}
build() {