summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-11-12 15:06:02 +0100
committerTorsten Keßler2021-11-12 15:06:02 +0100
commit192d7e215837a0b411f45ebace2a52c6a837eac1 (patch)
treeb50819aaf53bb0bbdab13277d4bcf8965bf634ef
parent0ea7d0c26f36efd121cb6d9cd61f683fbe0d024d (diff)
downloadaur-192d7e215837a0b411f45ebace2a52c6a837eac1.tar.gz
upgpkg: migraphx 4.5.0-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10096a2f0334..4132c962d24f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = migraphx
pkgdesc = AMD's graph optimization engine
- pkgver = 4.3.1
+ pkgver = 4.5.0
pkgrel = 1
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
license = MIT
makedepends = cmake
+ makedepends = rocm-cmake
makedepends = nlohmann-json
makedepends = half
makedepends = pybind11
- depends = rocm-cmake
+ depends = hip
depends = miopen
- depends = hip-rocclr
depends = protobuf
- depends = msgpack-c
+ depends = msgpack-cxx
depends = blaze
- source = migraphx-4.3.1.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-4.3.1.tar.gz
- sha256sums = e0b04da37aed937a2b2218059c189559a15460c191b5e9b00c7366c81c90b06e
+ source = migraphx-4.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-4.5.0.tar.gz
+ sha256sums = 8d243a48406af7f960c03bc28a16fad931de8e008ae848799adae504cc5f1355
pkgname = migraphx
diff --git a/PKGBUILD b/PKGBUILD
index 1c748fb25867..50a05cde350f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=4.3.1
+pkgver=4.5.0
pkgrel=1
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
-depends=('rocm-cmake' 'miopen' 'hip-rocclr' 'protobuf' 'msgpack-c' 'blaze')
-makedepends=('cmake' 'nlohmann-json' 'half' 'pybind11')
+depends=('hip' 'miopen' 'protobuf' 'msgpack-cxx' 'blaze')
+makedepends=('cmake' 'rocm-cmake' 'nlohmann-json' 'half' 'pybind11')
_git='https://github.com/ROCmSoftwarePlatform/AMDMIGraphX'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('e0b04da37aed937a2b2218059c189559a15460c191b5e9b00c7366c81c90b06e')
+sha256sums=('8d243a48406af7f960c03bc28a16fad931de8e008ae848799adae504cc5f1355')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {