summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-06-10 23:25:02 -0400
committeracxz2020-06-10 23:25:02 -0400
commit45ee4e75072ef0922ca4b79ac02ccdb1d3aa42f1 (patch)
tree24aa4398d443867a3de53aa42090029fb3d6475b
parentd17cad579c4be1c8de03041b9b578add6789dbc1 (diff)
downloadaur-45ee4e75072ef0922ca4b79ac02ccdb1d3aa42f1.tar.gz
updpkg migraphx
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6afc65741e4f..fffe52eb1a47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = migraphx
pkgdesc = AMD's graph optimization engine
- pkgver = 0.5.1
+ pkgver = 3.5.0
pkgrel = 1
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = migraphx
depends = protobuf
depends = half
depends = pybind11
- source = migraphx-0.5.1.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/0.5.1.tar.gz
- sha256sums = 2079dfe2e1efbe5e56015e056bf82f90d1645fa4a2610e20afa861697616e6af
+ source = migraphx-3.5.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-3.5.0.tar.gz
+ sha256sums = 5766f3b262468c500be5051a056811a8edfa741734a5c08c4ecb0337b7906377
pkgname = migraphx
diff --git a/PKGBUILD b/PKGBUILD
index a99094e81d1f..0ffa558818c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=0.5.1
+pkgver=3.5.0
pkgrel=1
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
@@ -8,16 +8,15 @@ url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'half' 'pybind11')
makedepends=('cmake')
-source=("migraphx-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/$pkgver.tar.gz")
-sha256sums=('2079dfe2e1efbe5e56015e056bf82f90d1645fa4a2610e20afa861697616e6af')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-$pkgver.tar.gz")
+sha256sums=('5766f3b262468c500be5051a056811a8edfa741734a5c08c4ecb0337b7906377')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
- "$srcdir/AMDMIGraphX-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
+ "$srcdir/AMDMIGraphX-rocm-$pkgver"
make
}