summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-05-02 16:06:27 +0200
committerTorsten Keßler2021-05-02 16:06:27 +0200
commit80def49147a7230b25657ebbc5ce962d61fccefb (patch)
tree01b3e2b4b61e4e5d09b704ebec71c89b00119286
parent7c43ff4569dce122ffdd0b19291b52f741be0d4f (diff)
downloadaur-80def49147a7230b25657ebbc5ce962d61fccefb.tar.gz
upgpkg: migraphx 4.1.0-1
upstream release new release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c13722de031..9f1ca1cd8030 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = migraphx
pkgdesc = AMD's graph optimization engine
- pkgver = 3.10.0
+ pkgver = 4.1.0
pkgrel = 1
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
license = MIT
makedepends = cmake
+ makedepends = nlohmann-json
depends = rocm-cmake
depends = miopen
depends = hip
depends = protobuf
- depends = half
depends = pybind11
- source = migraphx-3.10.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-3.10.0.tar.gz
- sha256sums = eda22b9af286afb7806e6b5d5ebb0d612dce87c9bad64ba5176fda1c2ed9c9b7
+ depends = msgpack-c
+ depends = blaze
+ source = migraphx-4.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-4.1.0.tar.gz
+ source = migraphx-4.1.0-half.tar.gz::https://github.com/ROCmSoftwarePlatform/half/archive/refs/tags/1.12.0.tar.gz
+ sha256sums = f9b1d2e25cdbaf5d0bfb07d4c8ccef0abaa291757c4bce296c3b5b9488174045
+ sha256sums = 0a08660b68abb176ebc2a0cdf8de46e3182a7f46c66443bb80dbfaaec98cf969
pkgname = migraphx
-
diff --git a/PKGBUILD b/PKGBUILD
index f91412b59dc1..02bcc2b06d0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
+# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=3.10.0
+pkgver=4.1.0
pkgrel=1
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
-depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'half' 'pybind11')
-makedepends=('cmake')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-$pkgver.tar.gz")
-sha256sums=('eda22b9af286afb7806e6b5d5ebb0d612dce87c9bad64ba5176fda1c2ed9c9b7')
+depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'pybind11' 'msgpack-c' 'blaze')
+makedepends=('cmake' 'nlohmann-json')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-$pkgver.tar.gz"
+ "$pkgname-$pkgver-half.tar.gz::https://github.com/ROCmSoftwarePlatform/half/archive/refs/tags/1.12.0.tar.gz")
+sha256sums=('f9b1d2e25cdbaf5d0bfb07d4c8ccef0abaa291757c4bce296c3b5b9488174045'
+ '0a08660b68abb176ebc2a0cdf8de46e3182a7f46c66443bb80dbfaaec98cf969')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
+ cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DCMAKE_PREFIX_PATH="$srcdir/half-1.12.0" \
"$srcdir/AMDMIGraphX-rocm-$pkgver"
make
}
@@ -24,11 +28,4 @@ package() {
cd "$srcdir/build"
make DESTDIR="$pkgdir" install
-
- # add links
- install -d "$pkgdir/usr/bin"
- local _fn
- for _fn in migraphx; do
- ln -s "/opt/rocm/migraphx/bin/$_fn" "$pkgdir/usr/bin/$_fn"
- done
}