summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-10-29 17:34:50 -0400
committeracxz2020-10-29 17:34:50 -0400
commit96b49487f2e69f78b07da0c24a4f4e8713e7a995 (patch)
tree04de4aff0d6a83cfbe505b0e474cb6c10efdb760
parent9dd55784f5b43b6cfb0b004e6ae675194532953b (diff)
downloadaur-96b49487f2e69f78b07da0c24a4f4e8713e7a995.tar.gz
[migraphx] updpkg 3.9.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90788759d0ea..afe4f021a050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = migraphx
pkgdesc = AMD's graph optimization engine
- pkgver = 3.8.0
+ pkgver = 3.9.0
pkgrel = 1
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = migraphx
depends = protobuf
depends = half
depends = pybind11
- source = migraphx-3.8.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/0.8.tar.gz
- sha256sums = 08fa991349a2b95364b0a69be7960580c3e3fde2fda0f0c67bc41429ea2d67a0
+ source = migraphx-3.9.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-3.9.0.tar.gz
+ sha256sums = 7649689e06522302c07b39abb88bdcc3d4de18a7559d4f6a9e238e92b2074032
pkgname = migraphx
diff --git a/PKGBUILD b/PKGBUILD
index 55a59f6b67a8..e82b2583c22e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
-pkgver=3.8.0
-_pkgver=0.8
+pkgver=3.9.0
pkgrel=1
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
@@ -9,15 +8,15 @@ url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
license=('MIT')
depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'half' 'pybind11')
makedepends=('cmake')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/$_pkgver.tar.gz")
-sha256sums=('08fa991349a2b95364b0a69be7960580c3e3fde2fda0f0c67bc41429ea2d67a0')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-$pkgver.tar.gz")
+sha256sums=('7649689e06522302c07b39abb88bdcc3d4de18a7559d4f6a9e238e92b2074032')
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
- "$srcdir/AMDMIGraphX-$_pkgver"
+ "$srcdir/AMDMIGraphX-rocm-$pkgver"
make
}