summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-10-29 14:51:28 +0200
committerTorsten Keßler2022-10-29 14:51:28 +0200
commitc51755f465f6a91e71a640694b327f2285bd034f (patch)
tree0a1e353f5aff93975c03ee09331b243bee3e7889
parentbc825694d72acd5fa8ac40f62802167f8f555b91 (diff)
downloadaur-c51755f465f6a91e71a640694b327f2285bd034f.tar.gz
upgpkg: migraphx 5.3.0-2
Add patch for C++ array header
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da2cf51b0cd7..9dc452466db4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = migraphx
pkgdesc = AMD's graph optimization engine
pkgver = 5.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
arch = x86_64
license = MIT
@@ -15,6 +15,8 @@ pkgbase = migraphx
depends = msgpack-cxx
depends = blaze
source = migraphx-5.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/rocm-5.3.0.tar.gz
+ source = include-array.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1435.patch
sha256sums = d0b7283f42e03fb38b612868b8c94f46f27a6e0b019ae95fde5b9086582a1c69
+ sha256sums = SKIP
pkgname = migraphx
diff --git a/PKGBUILD b/PKGBUILD
index c4b6ee9de459..bc6b7b4d8fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=migraphx
pkgver=5.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="AMD's graph optimization engine"
arch=('x86_64')
url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
@@ -10,10 +10,17 @@ license=('MIT')
depends=('hip' 'miopen' 'protobuf' 'msgpack-cxx' 'blaze')
makedepends=('rocm-cmake' 'nlohmann-json' 'half' 'pybind11')
_git='https://github.com/ROCmSoftwarePlatform/AMDMIGraphX'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('d0b7283f42e03fb38b612868b8c94f46f27a6e0b019ae95fde5b9086582a1c69')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
+ "include-array.patch::https://patch-diff.githubusercontent.com/raw/ROCmSoftwarePlatform/AMDMIGraphX/pull/1435.patch")
+sha256sums=('d0b7283f42e03fb38b612868b8c94f46f27a6e0b019ae95fde5b9086582a1c69'
+ 'SKIP')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
+prepare() {
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/include-array.patch"
+}
+
build() {
cmake \
-Wno-dev \