summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-03-14 13:09:58 -0400
committeracxz2020-03-14 13:09:58 -0400
commitd17cad579c4be1c8de03041b9b578add6789dbc1 (patch)
tree4456c642b0444ac97b3de3513fc2a57d881a0c31
downloadaur-d17cad579c4be1c8de03041b9b578add6789dbc1.tar.gz
create migraphx package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6afc65741e4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = migraphx
+ pkgdesc = AMD's graph optimization engine
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = rocm-cmake
+ depends = miopen
+ depends = hip
+ depends = protobuf
+ depends = half
+ depends = pybind11
+ source = migraphx-0.5.1.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/0.5.1.tar.gz
+ sha256sums = 2079dfe2e1efbe5e56015e056bf82f90d1645fa4a2610e20afa861697616e6af
+
+pkgname = migraphx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a99094e81d1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=migraphx
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="AMD's graph optimization engine"
+arch=('x86_64')
+url="https://rocmsoftwareplatform.github.io/AMDMIGraphX/doc/html/"
+license=('MIT')
+depends=('rocm-cmake' 'miopen' 'hip' 'protobuf' 'half' 'pybind11')
+makedepends=('cmake')
+source=("migraphx-$pkgver.tar.gz::https://github.com/ROCmSoftwarePlatform/AMDMIGraphX/archive/$pkgver.tar.gz")
+sha256sums=('2079dfe2e1efbe5e56015e056bf82f90d1645fa4a2610e20afa861697616e6af')
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/migraphx \
+ "$srcdir/AMDMIGraphX-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+
+ # add links
+ install -d "$pkgdir/usr/bin"
+ local _fn
+ for _fn in migraphx; do
+ ln -s "/opt/rocm/migraphx/bin/$_fn" "$pkgdir/usr/bin/$_fn"
+ done
+}