summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason SW2018-12-10 10:36:04 -0600
committerJason SW2018-12-10 10:36:04 -0600
commit108aa7297019e6ec234ca3f126ca004aa3ecc881 (patch)
tree00e3fb723bf410d61790656a550489fee0c52216
parent7c21a37fc217911b7475d5ae0b2b5d0a592fa100 (diff)
downloadaur-108aa7297019e6ec234ca3f126ca004aa3ecc881.tar.gz
Updated to version 1.2
-rw-r--r--PKGBUILD14
-rw-r--r--mikrolock.changes164
2 files changed, 171 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b751523f8b83..ee1ce93c73c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jason SW
pkgname=mikrolock
-pkgver=1.1
+pkgver=1.2
pkgrel=1
pkgdesc='A fast native implementation of the minilock file format that can read and write encrypted miniLock files.'
arch=('i686' 'x86_64')
@@ -16,23 +16,27 @@ changelog="$pkgname.changes"
source=("http://andre-simon.de/zip/$pkgname-$pkgver.tar.bz2"
"http://andre-simon.de/zip/$pkgname-$pkgver.tar.bz2.asc")
validpgpkeys=('B8C55574187F49180EDC763750FE0279D805A7C7')
-sha512sums=('74845d56961c0a2e391df911d2837ad02f6e140e1d1429d713d6714bc79d962f0b71a9fade2d850be8eb68dd04fb6dc603c6f4c3126dfcdef5ed9a4007639bd7'
+sha512sums=('e95aed063da2aed9fd59f7fb0054e55ad0cfcacf449445dc91108e3d73cf5e09b2c5b67a14221901822410529f7df440ea63f95d545d1f2861427e053902f75d'
'SKIP')
build() {
cd "$pkgname-$pkgver"
make
-pacman -T qt5-base >/dev/null && make gui
+if pacman -Qs qt5-base; then
+ make gui
+fi
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
-pacman -T qt5-base >/dev/null && make DESTDIR="$pkgdir" install-gui
ln -s "/usr/bin/mikrolock" "$pkgdir/usr/bin/mlock"
ln -s "/usr/share/man/man1/mikrolock.1.gz" "$pkgdir/usr/share/man/man1/mlock.1.gz"
-pacman -T qt5-base >/dev/null && ln -s "/usr/bin/mikrolock-gui" "$pkgdir/usr/bin/mlock-gui"
+if pacman -Qs qt5-base; then
+ make DESTDIR="$pkgdir" install-gui
+ ln -s "/usr/bin/mikrolock-gui" "$pkgdir/usr/bin/mlock-gui"
+fi
}
# vim: set ts=2 sw=2 et:
diff --git a/mikrolock.changes b/mikrolock.changes
index 0b568d6663a3..23da50c637a9 100644
--- a/mikrolock.changes
+++ b/mikrolock.changes
@@ -1,11 +1,19 @@
-04.06.2015
+06.03.2018
+
+MikroLock 1.2
+
+-GUI: added checkbox to show the passphrase
+
+---
+04.06.2016
MikroLock 1.1
-added Argon2 as possible key derivation function (--kdf)
-changed wording of miniLock-ID to Lock-ID
-GUI: added --portable command line option to save config files in the current
- working directory instead of the user directory
+ working directory instead of the user directory
+-GUI W32: shows progress in task bar (Windows 7 and later)
---
27.08.2015
@@ -15,3 +23,155 @@ MikroLock 1.0
-GUI: added translation hints
-GUI: drag and drop disabled if multiple files are dragged
-CLI: ignores own miniLock ID also in recipient list if -x is set
+
+---
+08.07.2015
+
+MikroLock 0.15
+
+-GUI: ignores own miniLock ID also in recipient list if "Omit my ID" is checked
+
+---
+02.07.2015
+
+MikroLock 0.14
+
+-name changed to MikroLock
+-minor documentation fixes
+
+---
+12.06.2015
+
+mlock 0.13
+
+-number of recipient IDs no longer restricted
+-GUI: fixed minor issues
+
+---
+04.06.2015
+
+mlock 0.12
+
+-increased allowed recipient ID count to 128
+-CLI: added --list option
+-GUI: fixed minor issues
+
+---
+18.05.2015
+
+mlock 0.11
+
+Most bugs + suggestions sent by Bene
+
+-GUI: changed bad mail format icon
+-GUI: fixed layout issues
+-GUI: added drag and drop icon
+-GUI: save out dir and encryption options
+-GUI: fixed threading issue
+-W32 CLI: fixed hash progress output
+-W32 CLI: fixed stripping of destination filename
+
+---
+14.05.2015
+
+mlock 0.10
+
+Bugs + suggestions sent by Bene
+
+-CLI: added -R option
+-GUI: added random output filename checkbox
+-GUI: added recipient list tooltips
+-GUI: fixed statusbar update issues
+-GUI: allows drag and drop only in the input/output screen
+-GUI: added browse destination directory button
+
+---
+05.05.2015
+
+mlock 0.9
+
+Bugs + suggestions sent by Bene & A. Sturthe
+
+-new errors if input file is empty or if output file exists
+-GUI: updated passphrase tooltips
+-GUI: fixed passphrase security notification
+-GUI: fixed encryption prompt after changing out directory
+-GUI: fixed diceware.com link clickability
+-GUI: added ID text file import and clear ID buttons
+-GUI: updated manual
+
+---
+01.05.2015
+
+mlock 0.8.1
+
+-Linux: fixed file open mode (thanks to Bene)
+
+---
+27.04.2015
+
+mlock 0.8
+
+-added README_DE and more icons/desktop integration files
+-CLI: added passphrase security hint
+-GUI: fixed UTF8 file path handling
+-GUI: added passphrase security notification icon
+-GUI: added manual
+-W32: added installer
+
+---
+17.04.2015
+
+mlock 0.7
+
+-CLI: fixed error message if passphrase or salt prevents decryption
+-GUI: replaced QML application by a new Widgets interface
+-GUI: mlock-gui may be invoked with a filename as first argument
+
+---
+02.04.2015
+
+mlock 0.6
+
+-fixed library linking order in src/makefile
+-CLI: added --quiet option
+-CLI: added hashing progress output
+
+---
+09.03.2015
+
+mlock 0.5
+
+-CLI: fixed progress output
+-GUI: added German translation, improved responsiveness
+
+---
+23.02.2015
+
+mlock 0.4
+
+-replaced crypto_scrypt call by libsodium's crypto_pwhash_scryptsalsa208sha256_ll
+-removed OpenSSL lib dependency
+
+---
+12.02.2015
+
+mlock 0.3
+
+-added optional QML GUI
+
+---
+21.11.2014
+
+mlock 0.2
+
+-added progress info output
+-replaced ftell by ftello and fseek by fseeko
+-added --pinentry flag
+
+---
+11.11.2014
+
+mlock 0.1
+
+-initial release