summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGomasy2018-03-10 18:11:52 +0900
committerGomasy2018-03-10 18:11:52 +0900
commit13ec26a2b8ceab0ebd207c7fb4ed2fe924c0e5da (patch)
treed7586f6db28784a21a6d5a20b2f3722e58221d39
parent57d8509e7595db4db70f598b6b98f89dac63276e (diff)
downloadaur-13ec26a2b8ceab0ebd207c7fb4ed2fe924c0e5da.tar.gz
Change gem's management to bundler
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
-rwxr-xr-xmikutter.desktop2
-rw-r--r--twitter-text.patch20
4 files changed, 12 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcfba5b3c881..b5d2f3e004d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,17 @@
pkgbase = mikutter
pkgdesc = a moest twitter client
pkgver = 3.6.5
- pkgrel = 1
+ pkgrel = 2
url = http://mikutter.hachune.net/
arch = i686
arch = x86_64
license = MIT
- depends = ruby-gtk2>=2.2.3
- depends = ruby-moneta
- depends = ruby-nokogiri
- depends = ruby-httpclient
- depends = ruby-mini_portile2
- depends = ruby-totoridipjp
- depends = ruby-gettext
- depends = ruby-native-package-installer
- depends = ruby-cairo-gobject
+ depends = ruby-bundler
optdepends = libnotify: notify support
source = http://mikutter.hachune.net/bin/mikutter.3.6.5.tar.gz
source = mikutter.desktop
- source = twitter-text.patch
md5sums = e07fb0b5ac8641999b5bb5bc64b997d6
- md5sums = 18e28a76097af88457462b08752382df
- md5sums = 6dc497afdbea6de76d0023e541f5d39c
+ md5sums = 3bc1c65e13b6182a9c989835eefc8810
pkgname = mikutter
diff --git a/PKGBUILD b/PKGBUILD
index abad522eab3e..5623bf2e5fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,33 @@
pkgname=mikutter
pkgver=3.6.5
-pkgrel=1
+pkgrel=2
pkgdesc="a moest twitter client"
arch=('i686' 'x86_64')
url="http://mikutter.hachune.net/"
license=('MIT')
-depends=(
-'ruby-gtk2>=2.2.3' 'ruby-moneta' 'ruby-nokogiri' 'ruby-httpclient' 'ruby-mini_portile2' 'ruby-totoridipjp'
-'ruby-gettext' 'ruby-native-package-installer' 'ruby-cairo-gobject'
-)
+depends=('ruby-bundler')
optdepends=('libnotify: notify support')
source=(
#http://mikutter.hachune.net/bin/$pkgname.$pkgver.tar.gz
http://mikutter.hachune.net/bin/$pkgname.`echo "$pkgver" | tr "_" '-'`.tar.gz
mikutter.desktop
-twitter-text.patch
)
-prepare() {
- cd $pkgname/vendor/twitter-text
- patch -u configuration.rb < "${srcdir}/twitter-text.patch"
+build() {
+ cd "$pkgname"
+ bundle install --path vendor/bundle --no-cache
}
package() {
mkdir "$pkgdir/opt"
cp -r "$srcdir/$pkgname" "$pkgdir/opt"
+ cp -r $srcdir/$pkgname/vendor/bundle/ruby/*/gems/twitter-text-*/config "$pkgdir/opt/$pkgname/"
mkdir -p "$pkgdir/usr/bin"
cat <<'EOF' > "$pkgdir/usr/bin/mikutter"
#!/bin/sh
-ruby /opt/mikutter/mikutter.rb $@
+BUNDLE_GEMFILE=/opt/mikutter/Gemfile bundle exec ruby /opt/mikutter/mikutter.rb $@
EOF
chmod a+x "$pkgdir/usr/bin/mikutter"
@@ -43,5 +40,4 @@ EOF
}
md5sums=('e07fb0b5ac8641999b5bb5bc64b997d6'
- '18e28a76097af88457462b08752382df'
- '6dc497afdbea6de76d0023e541f5d39c')
+ '3bc1c65e13b6182a9c989835eefc8810')
diff --git a/mikutter.desktop b/mikutter.desktop
index 88f97be3374f..c47d383ee2cb 100755
--- a/mikutter.desktop
+++ b/mikutter.desktop
@@ -4,5 +4,5 @@ Type=Application
Categories=Network
GenericName=mikutter
Icon=/opt/mikutter/core/skin/data/icon.png
-Exec=/usr/bin/ruby /opt/mikutter/mikutter.rb
+Exec=/usr/bin/mikutter
Terminal=false
diff --git a/twitter-text.patch b/twitter-text.patch
deleted file mode 100644
index bd35fd5cca09..000000000000
--- a/twitter-text.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- configuration_old.rb 2018-03-01 16:52:34.000000000 +0900
-+++ configuration.rb 2018-03-01 16:56:17.495500046 +0900
-@@ -6,7 +6,7 @@
- require 'json'
-
- PARSER_VERSION_CLASSIC = "v1"
-- PARSER_VERSION_DEFAULT = "v2"
-+ PARSER_VERSION_DEFAULT = "configuration"
-
- class << self
- attr_accessor :default_configuration
-@@ -21,7 +21,7 @@
- )
-
- CONFIG_V2 = File.join(
-- File.expand_path('../../../config', __FILE__), # project root
-+ File.expand_path('../../../core/plugin/twitter', __FILE__), # project root
- "#{PARSER_VERSION_DEFAULT}.json"
- )
-