summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpierre2020-05-08 18:33:39 +0200
committerpierre2020-05-08 18:33:39 +0200
commitd4c5bb3e56165d0a7697f0f0f1f7c9212a59741a (patch)
tree7755aeb350beca6120239204df6cbd833579cfc6
parent00f752addcdd193c4eeee8db787d0875c23a680b (diff)
downloadaur-d4c5bb3e56165d0a7697f0f0f1f7c9212a59741a.tar.gz
updated PKGBUID, use pre-built binary
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e47feec0255b..51a511b55006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = milcheck
- pkgdesc = A small binary that displays the status of your pacman mirrorlist in your terminal, written in Rust
- pkgver = 0.1.7
+ pkgdesc = A small binary that displays the status of your pacman mirrorlist in your terminal, written in Rust.
+ pkgver = 0.1.8
pkgrel = 1
url = https://github.com/doums/milcheck
arch = x86_64
- license = custom:Mozilla Public License v2.0
- makedepends = rust
- makedepends = cargo
- makedepends = git
- source = https://github.com/doums/milcheck/archive/v0.1.7.tar.gz
- sha256sums = 67577d03c39c106ed3f080cf60a4d6a428ef71b55f6b0035f36be375a6fdc26d
+ license = MPL2
+ depends = gcc-libs
+ source = https://github.com/doums/milcheck/releases/download/v0.1.8/milcheck
+ md5sums = d2e59fd9b1634805ea883f7b1f6ad479
pkgname = milcheck
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3132db745eca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+milcheck*
diff --git a/PKGBUILD b/PKGBUILD
index ec6d929bf5de..1f5298c549ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
-# Maintainer Joan Figueras <ffigue@gmail.com>
+# Maintainer: Pierre Dommerc <dommerc.pierre@gmail.com>
pkgname=milcheck
-pkgver=0.1.7
+pkgver=0.1.8
pkgrel=1
-makedepends=('rust' 'cargo' 'git')
+pkgdesc="A small binary that displays the status of your pacman mirrorlist in your terminal, written in Rust."
arch=('x86_64')
-pkgdesc="A small binary that displays the status of your pacman mirrorlist in your terminal, written in Rust"
url="https://github.com/doums/milcheck"
-license=('custom:Mozilla Public License v2.0')
-source=("https://github.com/doums/milcheck/archive/v${pkgver}.tar.gz")
-sha256sums=('67577d03c39c106ed3f080cf60a4d6a428ef71b55f6b0035f36be375a6fdc26d')
-
-build() {
- cd $pkgname-$pkgver
- cargo build --release
-}
+license=('MPL2')
+source=("https://github.com/doums/milcheck/releases/download/v${pkgver}/${pkgname}")
+depends=('gcc-libs')
+md5sums=('d2e59fd9b1634805ea883f7b1f6ad479')
package() {
- install -Dm755 $srcdir/$pkgname-$pkgver/target/release/${pkgname} $pkgdir/usr/bin/${pkgname}
+ dest="$pkgdir/usr/bin"
+ mkdir -p "$dest"
+ chmod 755 "$pkgname"
+ cp "$pkgname" "$dest"
}