summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpierre2020-10-12 21:58:08 +0200
committerpierre2020-10-12 21:58:08 +0200
commit1f9757eb17fcbcd498ec68ceb9bda3f1056d3f96 (patch)
tree5d9948089c9c883aaeb0b876761634b8c62021a3
parent1abf7eac48ab8f006c2d32a23a5291b52ec01ed1 (diff)
downloadaur-1f9757eb17fcbcd498ec68ceb9bda3f1056d3f96.tar.gz
new version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--update.md26
3 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5232789b32c0..cdbce75e642f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = milcheck-bin
pkgdesc = A small binary that displays the status of your pacman mirrorlist in your terminal
- pkgver = 0.1.9
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/doums/milcheck
arch = x86_64
license = MPL2
depends = gcc-libs
- source = milcheck-bin-0.1.9::https://github.com/doums/milcheck/releases/download/v0.1.9/milcheck
- md5sums = 3c088ceae3a1d02ab3211c552e839ef3
+ source = milcheck-bin-0.2.0::https://github.com/doums/milcheck/releases/download/v0.2.0/milcheck
+ md5sums = 2706a432196fd9817f4ea3704682aa3f
pkgname = milcheck-bin
diff --git a/PKGBUILD b/PKGBUILD
index c4c3af3bcac8..e42ab182f26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=milcheck-bin
_pkgname=milcheck
-pkgver=0.1.9
+pkgver=0.2.0
pkgrel=1
pkgdesc="A small binary that displays the status of your pacman mirrorlist in your terminal"
arch=('x86_64')
@@ -10,7 +10,7 @@ url="https://github.com/doums/milcheck"
license=('MPL2')
source=("$pkgname-$pkgver::https://github.com/doums/milcheck/releases/download/v${pkgver}/${_pkgname}")
depends=('gcc-libs')
-md5sums=('3c088ceae3a1d02ab3211c552e839ef3')
+md5sums=('2706a432196fd9817f4ea3704682aa3f')
package() {
install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
diff --git a/update.md b/update.md
new file mode 100644
index 000000000000..261227751d80
--- /dev/null
+++ b/update.md
@@ -0,0 +1,26 @@
+1. edit `PKGBUILD` file
+update the version number `pkgver=`
+
+2. update integrity checksum
+```
+$ makepkg -g
+```
+copy the output and paste it in `PKGBUILD` file, eg.
+```
+md5sums=('output')
+```
+source: https://wiki.archlinux.org/index.php/PKGBUILD#Integrity
+
+3. sanity check
+```
+$ namcap PKGBUILD
+$ makepkg
+$ namcap <package_name>.pkg.tar.xz
+```
+source: https://wiki.archlinux.org/index.php/Creating_packages#Checking_package_sanity
+
+4. generate `.SRCINFO`
+```
+$ makepkg --printsrcinfo > .SRCINFO
+```
+source: https://wiki.archlinux.org/index.php/.SRCINFO