summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit063b309ef3d681b6f0666a06123daa853e36cb42 (patch)
tree166852a3ea7cd8335217ea96fef870facf990add
downloadaur-063b309ef3d681b6f0666a06123daa853e36cb42.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cfbc814528a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = milena-abc
+ pkgdesc = Gtk3 gui for audiobook creator from Milena speech synthesizer
+ pkgver = 0.3.65
+ pkgrel = 1
+ url = http://milena.polip.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = milena
+ depends = libwebkit3
+ depends = gtksourceview3
+ depends = faac
+ depends = mpg123
+ depends = libsamplerate
+ depends = curl
+ source = http://tts.polip.com/files/milena_abc-0.3.65.tar.gz
+ sha256sums = dc19f33e3a2190e0d6c92ee1f18ff5c79ae71c5e25213fa432e119e009f3b25a
+
+pkgname = milena-abc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9df6b626fd44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
+
+pkgname=milena-abc
+pkgver=0.3.65
+pkgrel=1
+pkgdesc="Gtk3 gui for audiobook creator from Milena speech synthesizer"
+arch=('i686' 'x86_64')
+url="http://milena.polip.com/"
+license=('GPL')
+depends=(milena libwebkit3 gtksourceview3 faac mpg123 libsamplerate curl)
+source=(http://tts.polip.com/files/${pkgname//-/_}-${pkgver}.tar.gz)
+sha256sums=('dc19f33e3a2190e0d6c92ee1f18ff5c79ae71c5e25213fa432e119e009f3b25a')
+
+build() {
+ cd "$srcdir/${pkgname//-/_}-${pkgver}"
+
+ ./configure --prefix=/usr
+ make
+
+ # FIX: Bad place for icons, change from name to path.
+ sed -e 's:^Icon=.*:Icon=/usr/share/icons/milena_abc.xpm:' \
+ -i milena_abc.desktop
+}
+
+package() {
+ cd "$srcdir/${pkgname//-/_}-${pkgver}"
+
+ # FIX: "make install" should create this folders automaticly.
+ install -dm755 "$pkgdir"/usr/{bin,share/{applications,icons,milena_abc}}
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: