summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-24 03:54:36 +0300
committerDimitris Kiziridis2020-04-24 03:54:36 +0300
commit2d3e2dc0653ea7b034ccb6da00e82b1d88c3bb6d (patch)
tree4a31546e2b494a6b2dc73bc8e958db56fe23e06c
downloadaur-2d3e2dc0653ea7b034ccb6da00e82b1d88c3bb6d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91ba681c02f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = mimemagic
+ pkgdesc = Powerful and versatile MIME sniffing package using pre-compiled glob patterns, magic number signatures, XML document namespaces, and tree magic for mounted volumes, generated from the XDG shared-mime-info database
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/zRedShift/mimemagic
+ arch = x86_64
+ license = MIT
+ makedepends = dep
+ makedepends = go-pie
+ source = https://github.com/zRedShift/mimemagic/archive/v1.1.0.tar.gz
+ sha256sums = 3f20e5a7e28080c3dd23721d40d9d419509f26e38c69f11b2c9838c8b41a1927
+
+pkgname = mimemagic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aff530bb3dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=mimemagic
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Powerful and versatile MIME sniffing package using pre-compiled glob patterns, magic number signatures, XML document namespaces, and tree magic for mounted volumes, generated from the XDG shared-mime-info database"
+arch=('x86_64')
+url='https://github.com/zRedShift/mimemagic'
+license=('MIT')
+makedepends=('dep' 'go-pie')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('3f20e5a7e28080c3dd23721d40d9d419509f26e38c69f11b2c9838c8b41a1927')
+
+prepare() {
+ mkdir -p gopath/src/github.com/${pkgname}
+ ln -rTsf ${pkgname}-${pkgver} gopath/src/github.com/${pkgname}/${pkgname}
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname}/${pkgname}
+ dep init -v
+ dep ensure -v
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/${pkgname}/${pkgname}/cmd/${pkgname}
+ go install -v .
+}
+
+package() {
+ install -Dm755 "${srcdir}/gopath/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file