summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaylorchu2015-06-17 15:45:25 -0700
committertaylorchu2015-06-17 15:45:25 -0700
commitdd450a88850d0b88b80706e102d6b1c314bf9e2d (patch)
tree6e172515ae3b9d897bce9339cf1f6719b99de056
downloadaur-dd450a88850d0b88b80706e102d6b1c314bf9e2d.tar.gz
upgpkg: mimi-git 60.2758674-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af11513eefc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mimi-git
+ pkgdesc = best alternative to xdg-open (git version)
+ pkgver = 60.2758674
+ pkgrel = 1
+ url = http://github.com/taylorchu/mimi
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = bash
+ depends = dmenu
+ provides = xdg-utils
+ conflicts = xdg-utils
+ source = git://github.com/taylorchu/mimi.git
+ md5sums = SKIP
+
+pkgname = mimi-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c5c0df28b94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: tailinchu <use_my_id at gmail dot com>
+
+pkgname=mimi-git
+pkgver=60.2758674
+pkgrel=1
+pkgdesc="best alternative to xdg-open (git version)"
+arch=('any')
+url="http://github.com/taylorchu/mimi"
+license=('GPL2')
+depends=('bash' 'dmenu')
+makedepends=('git')
+conflicts=('xdg-utils')
+provides=('xdg-utils')
+source=("git://github.com/taylorchu/mimi.git")
+md5sums=('SKIP')
+
+_gitroot="mimi"
+
+pkgver () {
+ cd "$srcdir/$_gitroot"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package() {
+ cd "$srcdir/$_gitroot"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+